Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 24
  1. #1

    Basic question about OEM, RXP waterbox

    Hi, Im very curious if there's any proof out there at all showing a difference in performance between an OEM (05 RXP) waterbox that has been modded with the holes drilled, and another (same box) one with the baffles torn out all together?? In this comparison, is there any proof or knowledge of torque/power loss between ^those^ altered waterboxes?

    I'm asking because my waterbox recently had it's baffles fall apart and I removed all 4 pieces that were in there....now, the ski feels a little different (I know my ski's attitude very well). The power is what I describe as a little "softer" and peak speeds/RPMs seem to maybe be harder to achieve.

    Thanks!


  2. #2
    83.0 @ 8400 jhill19's Avatar
    Join Date
    Jul 2010
    Location
    Teays Valley, West Virginia
    Posts
    2,800
    +1
    81
    Did you get everything sealed up good? might have an exhaust leak

  3. #3
    At the moment I'm pretty confident everything is all buttoned up pretty good. So, The only mechanical difference would be the waterbox internals.

  4. #4
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    Quote Originally Posted by blkturbo! View Post
    At the moment I'm pretty confident everything is all buttoned up pretty good. So, The only mechanical difference would be the waterbox internals.
    Very little if any perf increase. More about sound bro. You sure it's not just a temp diffetence you are feeling?

  5. #5
    83.0 @ 8400 jhill19's Avatar
    Join Date
    Jul 2010
    Location
    Teays Valley, West Virginia
    Posts
    2,800
    +1
    81
    Quote Originally Posted by blkturbo! View Post
    At the moment I'm pretty confident everything is all buttoned up pretty good. So, The only mechanical difference would be the waterbox internals.
    Yeah I thought I was confident I didn't have a leak too. I lost several hundred rpm's & softer performance, put another clamp on it and it was fine.

  6. #6
    Quote Originally Posted by Ocman View Post
    Very little if any perf increase. More about sound bro. You sure it's not just a temp diffetence you are feeling?
    Yea I'm in the process of ruling out/confirming any weather difference. Although similar weather between now and a couple weeks ago. But as far as performance, I'm suspicious of possibly having *too little* back pressure (and making less power). was wondering if that was a possible issue anyone has ever noticed or confirmed before (I mean, before I blame it all on a 5% weather change )

  7. #7
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    Like discussed before, your box was modded improperly. The deflection baffle was compromised, and broke apart. The outlet tube was not trimmed, so you aren't gaining anything. You can still have debris from the breakup, which affects flow of both water and air through the waterbox.

    Plus, what are your AFR's right now? Too much, too little fuel will soften the motor quickly.

  8. #8
    Yea I agree it wasn't modded properly. But my concern is whether or not these boxes lose torque when all baffling comes out. So in this thread, I'm looking to compare my box before and my box after the baffling issue. If it is known that power can be lost with a total gut vs just the standard holes etc, then yes, I'll be looking to replace this particular box in order to get back to where I was (performance-wise) last month.

  9. #9
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    Plus you have a 3" intake, which is choking that Xcharger up top. I think you said you had a 4" waiting to go in.

  10. #10
    True. Waiting to throw in the 4in until power commander says I'm safe. Meanwhile, focus is on post-baffle removal and possible lack of back pressure. I don't believe in performing "B" to cure problem "A".
    I prefer to fix "A" to cure problem "A". Then I move forward

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. couple questions about my RXP
    By spark in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-21-2007, 11:04 PM
  2. New to forums and have a few questions about a RXP
    By class act in forum 4-Tec Performance
    Replies: 8
    Last Post: 03-13-2007, 01:59 PM
  3. Question about OEM pipe
    By NeVerMind in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 07-17-2006, 05:31 PM
  4. Question about 06 rxp
    By sleeplessnMS in forum 4-Tec Performance
    Replies: 0
    Last Post: 04-13-2006, 09:08 PM
  5. A few questions about my RXP
    By Teddy57 in forum 4-Tec Performance
    Replies: 2
    Last Post: 01-28-2006, 02:22 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •