Results 1 to 6 of 6
  1. #1

    HELP 2003 rebuild sc with 3 spacer washers? HELP

    Hey all,

    I am installing the sc after it came back from Jerry today. He included the 3 "spacer" washers that mount between the sc and the engine at the 3 mounting bolts. Now that I have it installed, I notice that the sc near the part with the o rings now sits out from the engine..but I have the washers as spacers so assume it is because the rebuilt shaft is longer than the stock one? Need to make sure I am not getting an issue before I finish all the other install of the hoses...Is this normal?
    Thanks.


  2. #2
    Codeman666's Avatar
    Join Date
    Aug 2007
    Location
    sunny south florida
    Posts
    179
    +1
    8
    Quote Originally Posted by Velodrome View Post
    Hey all,

    I am installing the sc after it came back from Jerry today. He included the 3 "spacer" washers that mount between the sc and the engine at the 3 mounting bolts. Now that I have it installed, I notice that the sc near the part with the o rings now sits out from the engine..but I have the washers as spacers so assume it is because the rebuilt shaft is longer than the stock one? Need to make sure I am not getting an issue before I finish all the other install of the hoses...Is this normal?
    Thanks.


    Yes if your supercharger is for the 185 non intercooled supercharged skis the spacers are needed and damage could result if not installed

  3. #3
    I just was startled about how much the male part of the sc that was prev. flush with the engine housing now sits about an 1/8" away..from it. I have the washers between the sc and the engine and torqued so I guess I will move on and hope that the o rings do their thing. Thanks for the reply!

  4. #4
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Perfectly normal!

    The spacer washers are only used on supercharger housings with a serial number ending in "3"

  5. #5
    lextoy's Avatar
    Join Date
    Jan 2007
    Location
    Brigantine, NJ
    Posts
    1,883
    +1
    14
    you can throw a good high temp marine grease on that exposed metal to help protect it, blob it on like toothpaste. i smeared light coating all over the base of the shaft, btw o rings etc and then inserted, then a big blob where the Sc meets the engine.
    it will melt a bit and run all the way around.
    this makes pulling the SC the next time, super easy !!! other wise corrosion will get in there and freeze the SC to the block, making it a royal PITA to remove.
    it took me 2 hours the firs ttime to remove my SC, 2nd time it slid out nice and easy.
    also put some never seize on the mounting bolts so they dont get frozen up, that one reverse bolt can be a problem if you strip it cuz its frozen.

  6. #6
    Puts motor oil on his pancakes Hockeydude's Avatar
    Join Date
    Oct 2011
    Location
    Grand Blanc, MI
    Posts
    64
    perfectly normal, I have a '03 as well that I rebuilt last fall. The reason for the spacers is the gear on the supercharger was not lined up perfectly center with the fly wheel from the factory. The washers line it up correctly. If you looked at the old gear on your supercharger before you sent it to Jerry you could probably see minor wear on the gear but only on 3/4 of one side of the gear.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2003 GTX-SC with Riva Stage 1 performing poorly
    By SBINBRANSON in forum 4-Tec Performance
    Replies: 1
    Last Post: 08-05-2010, 08:42 PM
  2. FS stock 07 215 hp SC with fresh 08 rebuild kit (ss washers)
    By Jim-C180 in forum Sea Doo Classifieds
    Replies: 13
    Last Post: 04-02-2010, 11:03 PM
  3. FS - RR high boost SC with 2mm spacer
    By dhoad in forum Sea Doo Classifieds
    Replies: 17
    Last Post: 09-24-2008, 08:18 AM
  4. 2003 GTX SC Rebuild Help Please!?
    By GTXDawg in forum 4-Tec Performance
    Replies: 42
    Last Post: 05-27-2008, 04:48 PM
  5. 2003 GTX SC not getting up to Speed Or RPMs ! Help !
    By RXPBeast in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 06-11-2006, 09:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •