Results 1 to 5 of 5
  1. #1

    Question 2005 FX HO Cruiser Overheating at high speeds

    Hi guys i have a 2005 FXHO Cruiser that i put a new SBT engine in last fall and i did most of the breakin with no trouble at all untill i got up to the 80% throttle range of the breakin when it started to overheat. I will not overheat until i get into the 70-80 % throttle. I get the overheat buzzer and limp mode. It takes a good mile or 2 of running that fast to get it to overheat. I called SBT and they said its probly a bad overheat sensor. I see theres 3 thermo sensors on this thing. They said its probly the one in the exhaust pipe. Just wondering if you guys have any advice or agree with what they are saying. The ski runs great and has great power other than that problem!

    Thanks
    Adam


  2. #2
    If its a bad sensor, you usually get an error code on the display. The exhaust temperature sensor malfunction would show a code "53". If you don't get a code then I'd be more inclined to think you might have a blockage in the system. I'd start by pulling the thermostat, since this is where debris often gets stuck.

    On the display what symbol lights when you get the buzzer? It should show whether its the engine or exhaust that is triggering the alarm. The sensors, and thermo-switches can be tested, by removing them an heating them up while measuring resistance.

  3. #3

    fxho overheat

    Its the 3rd symbol over from the rt side of the guage. Its a overheat symbol that comes on. Does it actually show the code number while its happening or do i need to check it for codes, if so is there a way to check the codes without the software? I know there is no code showing when the overheat occurs.
    Thanks
    Adam

    Quote Originally Posted by Ernest T View Post
    If its a bad sensor, you usually get an error code on the display. The exhaust temperature sensor malfunction would show a code "53". If you don't get a code then I'd be more inclined to think you might have a blockage in the system. I'd start by pulling the thermostat, since this is where debris often gets stuck.

    On the display what symbol lights when you get the buzzer? It should show whether its the engine or exhaust that is triggering the alarm. The sensors, and thermo-switches can be tested, by removing them an heating them up while measuring resistance.

  4. #4

    Over heating

    How can you tell if its a engine overheat or an exhaust overheat. If its not a sensor telling it that its overheating then what throws the alarm? I am getting 01 code but i have had the battery disconnected since it last overheated. I have taken the pump off and checked the screen and its clear and i also checked the hoses and they are clear and not kinked anywhere. I do remember getting the overheat symbol and going into lymp mode. I took out the thermostat and put it in water and heated it up and it opens at 129 F which i assume is ok cause its a 122 f thermistat. I also checked both pissers and they are clear also. I have seen some people on here have the same problems i have and they changed the plugs and it went away but i don't see how spark plugs could cause this problem and i only have 4 hours on the plugs and new engine.

    Quote Originally Posted by acalley02 View Post
    Its the 3rd symbol over from the rt side of the guage. Its a overheat symbol that comes on. Does it actually show the code number while its happening or do i need to check it for codes, if so is there a way to check the codes without the software? I know there is no code showing when the overheat occurs.
    Thanks
    Adam

  5. #5

    Join Date
    Sep 2010
    Location
    Aliso Viejo
    Posts
    951
    +1
    75
    Only time you will see the error code is to push the button right after this happens and see the code!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB Yamaha fx ho cruiser seat....2005-07
    By RSM in forum Yamaha Classifieds
    Replies: 6
    Last Post: 09-27-2017, 05:00 AM
  2. 2012 Yamaha FX HO Cruiser stability at idle
    By OZFXSHO in forum Yamaha PWC Performance (4-stroke)
    Replies: 3
    Last Post: 01-10-2012, 05:58 PM
  3. WTB 2005 FX HO Cruiser Display
    By steelroe in forum Yamaha Classifieds
    Replies: 15
    Last Post: 06-02-2010, 01:07 PM
  4. 2005 FX HO Cruiser Display Questions
    By steelroe in forum Yamaha Open Discussion
    Replies: 1
    Last Post: 04-30-2010, 06:54 AM
  5. Reliability of 2005 Yamaha FX HO Cruiser?
    By Piraya33 in forum Yamaha PWC Performance (4-stroke)
    Replies: 21
    Last Post: 05-09-2008, 09:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •