Results 1 to 3 of 3
  1. #1

    polaris 1999 SLTX WON'T STAY RUNNING

    I have a 1999 polaris SLTX that I've been trying to get running i've replaced the stator and control box. now I'm trying to run the motor out of the ski to verify that the problem is fixed before reassembley, but i can't seem to keep the motor running. the motor starts for a few seconds but then shuts off, so my question is
    1. is there anything in the wiring going to the control handle that needs to be wired in series or grounded.

    2. do the carburators need a constant pressure via fuel pump to keep running or can i run it straight from from a test tank.


  2. #2
    Polaris?

    Maybe better response if you post here:-

    http://www.greenhulk.net/forums/forumdisplay.php?f=59

  3. #3
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Quote Originally Posted by gonguam View Post
    I have a 1999 polaris SLTX that I've been trying to get running i've replaced the stator and control box. now I'm trying to run the motor out of the ski to verify that the problem is fixed before reassembley, but i can't seem to keep the motor running. the motor starts for a few seconds but then shuts off, so my question is
    1. is there anything in the wiring going to the control handle that needs to be wired in series or grounded.

    2. do the carburators need a constant pressure via fuel pump to keep running or can i run it straight from from a test tank.
    Did you replace the stator and CDI with the updated versions? The carbs have 2 fuel pumps mounted to them, one on each end carb. Does your ski still have the grey fuel lines? If so, they need to be replaced and your carbs should be cleaned/rebuilt. You must disassemble the carbs to clean them, Seafoam will not do it. Check your compression, make sure its within spec. Make sure your fuel valve is clean and operating properly.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Polaris TXI Won't Stay Running
    By gswanson in forum Polaris Open Discussion
    Replies: 5
    Last Post: 11-08-2015, 12:51 PM
  2. Waveblaster won't stay running
    By bassdocktor in forum Yamaha Old School Skis
    Replies: 8
    Last Post: 06-11-2010, 05:44 PM
  3. boat won't stay running
    By goBENGALS in forum Polaris Open Discussion
    Replies: 3
    Last Post: 05-24-2009, 11:41 PM
  4. 03 GTX SC won't stay running
    By INSMAN in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 08-14-2007, 03:07 PM
  5. 2000 SLX 1200 Won't Stay Running
    By 5001craig in forum Polaris Open Discussion
    Replies: 12
    Last Post: 07-17-2007, 01:51 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •