Results 1 to 6 of 6
  1. #1

    Need SBN 44I fuel pump cover for my GP800R

    When I was rebuilding my GP800R carbs, I scraped a little too much when trying to remove gasket off the pump cover side of the carb. I know...I shouldnt have scraped but I did and when I rebuilt carbs, I think i am not getting good seal. They are adjusted to factory settings and everything starts and runs great on the first shot but when we are out and stop for 30+ minutes...I start back up and it bogs for 30 sec, then clears and runs good. Also, wants to death rev when on hose. Seems like a lean condition not sure if pump is putting enough fuel to engine. All hoses attached, everything torqued proper. Ski runs great and fast but has the bog condition after subsequent starts. Seems like fuel pressure is not there right after starts, but it eventually comes back. I really think this is related to fuel pump.


  2. #2

    Join Date
    Aug 2006
    Location
    Indiana
    Posts
    1,274
    +1
    81
    If by death rev you mean extra high rpm idle even when you shut it down, that would be too much air from either idle stop set to far open, or an air leak. If you have stock (hi) pop-off settings on carb, if the fuel pump is compromised, it will not pump enough pressure to open the pop-off, so that is could be part of the issue. You may want to reduce pop-off pressure if its set high like the 1200r is.

  3. #3
    Changed needles and seats,Reset pop off to 40 and changed fuel lines/filter...first start it still seems to want to runaway when revving on trailer, doesnt quite do it...close.

    Side note, not sure if it's related but, when replacing fuel lines the on connection on top of tank seems to be loose, can spin it around, seems like no pressure in tank.

  4. #4

    Join Date
    May 2009
    Location
    Lake Worth, FL
    Posts
    27
    Quote Originally Posted by aflax24 View Post
    Changed needles and seats,Reset pop off to 40 and changed fuel lines/filter...first start it still seems to want to runaway when revving on trailer, doesnt quite do it...close.

    Side note, not sure if it's related but, when replacing fuel lines the on connection on top of tank seems to be loose, can spin it around, seems like no pressure in tank.
    Check your check valve, and the vent hose. On my ski it was clogged. And the fuel sending unit should not spin freely.

  5. #5
    Not sure if you are looking for carb parts still but I have a complete sbn44 that the needle retainer screw thing snapped off on so the body is trashed, but that's available and I also have a complete mikuni rebuild kit for a 44 as well...all for a minimal price.......

  6. #6
    Ended up just smoothing it out with a little light sand paper. Worked great.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Aftermarket fuel pump options for FZS, help needed
    By cmgww in forum Yamaha PWC Performance (4-stroke)
    Replies: 20
    Last Post: 06-05-2016, 11:09 AM
  2. Need advice on fuel pump for rxp
    By Jeff C in forum 4-Tec Performance
    Replies: 24
    Last Post: 09-20-2014, 12:26 PM
  3. WTB need a solas concord 15/20 for my 951 pump
    By JLewis in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 09-26-2011, 01:04 PM
  4. Need cover for my 03 fx cruiser
    By sdman in forum Yamaha PWC Performance (4-stroke)
    Replies: 0
    Last Post: 08-17-2010, 08:23 AM
  5. Replies: 2
    Last Post: 07-17-2008, 01:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •