Results 1 to 4 of 4
  1. #1

    Join Date
    May 2009
    Location
    Lake Worth, FL
    Posts
    27

    2001 seadoo GS 717 starting problems.

    so im working on my buddies seadoo. when you hit start button i hear the solinoid click but sometimes the starter would turn over and others not. so i replaced the starter which need to be changed (alot of play in the shaft) and the problem is still there. not as bad as before but still there. The solinoid is clicking so didnt think that was the problem but i guess it might be. could the solinoid not be strong enough? i never heard of solinoid clicking but not working? Thanks


  2. #2
    Those solinoids do fail quite often. It could also be the wire to the starter. Take your multi-meter or 12v test light and put it on the starter stud where the wire is held on. When you hit the button you should get 12v to the starter. You could cross the solinoid studs and see if the starter hits every time. That would mean that the wire and new starter check out. Sometimes a "click" means that the engine is hydrolic locking from a flooding carb or something else. Pull your plugs (and ground the 2 plug wires out) to see if it will spin that way.

  3. #3
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    Quote Originally Posted by Matt Braley View Post
    Those solinoids do fail quite often. It could also be the wire to the starter. Take your multi-meter or 12v test light and put it on the starter stud where the wire is held on. When you hit the button you should get 12v to the starter. You could cross the solinoid studs and see if the starter hits every time. That would mean that the wire and new starter check out. Sometimes a "click" means that the engine is hydrolic locking from a flooding carb or something else. Pull your plugs (and ground the 2 plug wires out) to see if it will spin that way.
    could be a weak battery or bad solenoid. also check your cables

  4. #4

    Join Date
    May 2009
    Location
    Lake Worth, FL
    Posts
    27
    Ok so I forgot to mention one cable is brand new and the other in great shape. Tested with plugs out and made no difference. Battery is good. Going to change solenoid first see what happens. Thanks everyone will keep posted.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2001 seadoo xp 951 throttle problems? Taking on water?
    By 951 XP NC in forum 2-Stroke Performance
    Replies: 5
    Last Post: 04-07-2014, 12:05 AM
  2. 2001 Seadoo GTX DI bogging problem
    By Aaronm in forum 2-Stroke Performance
    Replies: 3
    Last Post: 04-17-2013, 03:04 PM
  3. 98 seadoo gs wont start with start button
    By XP537 in forum 2-Stroke Performance
    Replies: 11
    Last Post: 10-16-2011, 08:57 PM
  4. 2001 Seadoo GS Engine Replacement....What else to inspect
    By bigbadb in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 02-27-2009, 11:04 AM
  5. 2001 SeaDoo GS...62mph!!!
    By PhilnEdee in forum 2-Stroke Performance
    Replies: 0
    Last Post: 09-11-2007, 03:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •