Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1

    Join Date
    Apr 2012
    Location
    Gary, TX
    Posts
    6

    1995 polaris sl650 problems

    Can anyone help me? Just bought 2 1995 polaris sl650's and I am having issues with one. The middle cylinder keeps spitting fuel and oil back through carb. middle carb looks like it has smoke coming back through it when the ski dies. Sounds like it is running good but smokes really bad. Any help would be appreciated.


  2. #2
    Polarisitis loonatik's Avatar
    Join Date
    May 2010
    Location
    Tampa, FL
    Posts
    812
    +1
    10
    Welcome to GH!
    Sounds like you have bad reeds.

    Those skis are almost 20 years old, be sure that all maintenance is up to date before taking them to the water, Check out this link below to get you started:
    http://www.greenhulk.net/forums/showthread.php?t=148277

  3. #3

    Join Date
    Apr 2012
    Location
    Gary, TX
    Posts
    6
    When I pull the reeds out how do I tell if they are bad?

  4. #4
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    They'll be cracked, broken, or staying open.

    Welcome to the Hulk BTW

  5. #5

    Join Date
    Apr 2012
    Location
    Gary, TX
    Posts
    6
    pulled the reeds out of my engine and found out that they were all bad, but the middle set was the worse.



  6. #6
    Buck3yeRideR's Avatar
    Join Date
    Jun 2011
    Location
    Brunswick/Marblehead, OH
    Posts
    108
    ^for the image link to work you have to upload your photos to a hosting site like photobucket

  7. #7
    johnsonmtz's Avatar
    Join Date
    Oct 2006
    Location
    Mt. Zion Illinois
    Posts
    1,250
    +1
    7
    I'll have to look, But I may have a good set of OEM reeds that I can hook you up with.

    KJ

  8. #8

    Join Date
    Apr 2012
    Location
    Gary, TX
    Posts
    6
    that would be awesome if you still have them. would be greatly appreciated

  9. #9

    Also have a 95 sl650

    I have a sl650 that we bought it was a little rough to get started but we did. Now you can ride it for an hour or so then it shuts down, sometimes if you put on the reserve you can start it, but it will not start. Any idea of what this could be?

  10. #10
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Quote Originally Posted by mljack04 View Post
    sometimes if you put on the reserve you can start it, but it will not start.
    Say what????

    And welcome to the Hulk.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1995 Polaris SL650 - Installed new battery, no crank
    By mterry127 in forum Polaris Open Discussion
    Replies: 18
    Last Post: 08-05-2012, 01:26 PM
  2. FS: 1995 Polaris SL650
    By taylor3609 in forum Polaris Skis
    Replies: 2
    Last Post: 05-01-2011, 09:31 AM
  3. Stator for a 1995 polaris sl650.
    By stephen kalafut in forum Polaris Open Discussion
    Replies: 1
    Last Post: 07-12-2010, 10:08 PM
  4. FS Parting out 1995 Polaris SL650
    By koryk in forum Polaris Classifieds
    Replies: 3
    Last Post: 06-05-2010, 01:39 PM
  5. 1995 polaris sl650
    By shphd57 in forum Polaris Open Discussion
    Replies: 13
    Last Post: 06-30-2007, 11:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •