Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 23

Thread: Sho engine code

  1. #1
    tealgreen2000's Avatar
    Join Date
    Jul 2010
    Location
    miami gardens
    Posts
    305
    +1
    8

    Sho engine code

    Ive got a 2009 sho that just got back out to ride since last summer started it up a the check engine comes on i held the buttons to get the code its says 15 i was told thats the engine temp sensor does anyone know where its located an is that the right sensor for that code thanks for ant help


  2. #2

    Join Date
    Mar 2010
    Location
    the moon
    Posts
    862
    +1
    19
    15 is definately engine temp sensor malfunction. look in the online parts store to locate it you'll find it in there.

  3. #3
    01 Normal
    13 Pickup coil malfunction
    15 Engine temperature sensor malfunction
    18 Throttle position sensor malfunction
    19 Incorrect battery voltage
    23 Intake air temperature sensor malfunction
    24 Cam position sensor malfunction
    29 Intake air pressure sensor malfunction
    47 Slant detection switch malfunction
    48 Incorrect data transmission
    54 Bypass valve motor malfunction
    55 Steering switch malfunction
    63 Intake air system malfunction

  4. #4
    VinceC's Avatar
    Join Date
    Mar 2011
    Location
    Palmetto, Florida, United States
    Posts
    727
    +1
    56
    Thank you very much for this. I did a online search after the initial question and couldn't find a answer. Any chance you know the procedure (pushing buttons) to bring the code to the display?

    Quote Originally Posted by misterjay View Post
    01 Normal
    13 Pickup coil malfunction
    15 Engine temperature sensor malfunction
    18 Throttle position sensor malfunction
    19 Incorrect battery voltage
    23 Intake air temperature sensor malfunction
    24 Cam position sensor malfunction
    29 Intake air pressure sensor malfunction
    47 Slant detection switch malfunction
    48 Incorrect data transmission
    54 Bypass valve motor malfunction
    55 Steering switch malfunction
    63 Intake air system malfunction

  5. #5
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,194
    +1
    536
    Quote Originally Posted by tealgreen2000 View Post
    Ive got a 2009 sho that just got back out to ride since last summer started it up a the check engine comes on i held the buttons to get the code its says 15 i was told thats the engine temp sensor does anyone know where its located an is that the right sensor for that code thanks for ant help
    It's located right rear of the engine

  6. #6
    tealgreen2000's Avatar
    Join Date
    Jul 2010
    Location
    miami gardens
    Posts
    305
    +1
    8
    Quote Originally Posted by VinceC View Post
    Thank you very much for this. I did a online search after the initial question and couldn't find a answer. Any chance you know the procedure (pushing buttons) to bring the code to the display?
    hold the two buttons with the ski running an the code will come up

  7. #7
    tealgreen2000's Avatar
    Join Date
    Jul 2010
    Location
    miami gardens
    Posts
    305
    +1
    8
    Quote Originally Posted by JIM'S PERFORMANCE View Post
    It's located right rear of the engine
    thanks for the help

  8. #8
    Quote Originally Posted by VinceC View Post
    Thank you very much for this. I did a online search after the initial question and couldn't find a answer. Any chance you know the procedure (pushing buttons) to bring the code to the display?

    Hold the button down on the dash for 10 - 15 seconds while ski is running and you will get your appropriate code .....

  9. #9

    Join Date
    Apr 2015
    Location
    Wales, UK
    Posts
    660
    +1
    35
    Bumping an old thread my 08 SHO threw me temp warnings all afternoon (cooling water outlets all good) then after 10+ Miles in limp mode restarted and ski was off like a scalded cat! Got out the water on trailer the. I threw check engine showing code 15 on display ( engine temp sensor )

    is it as as simple as replace sensor and all good? Ski is on 110 hours there was a temp warning at about 60 hours in the ecu which a mechanic reset for me last year
    Last edited by HDAV; 04-02-2017 at 01:30 PM.

  10. #10
    CHINE WALKER nicor6's Avatar
    Join Date
    Jun 2014
    Location
    Mahe
    Posts
    376
    +1
    43
    Quote Originally Posted by HDAV View Post
    Bumping an old thread my 08 SHO threw me temp warnings all afternoon (cooling water outlets all good, then after 10+ Miles in limp mode restarted and ski was off like a scalded cat! Got out the water on trailer the. I threw check engine showing code 15 on display ( engine temp sensor )

    is it as as simple as replace sensor and all good? Ski is on 110 hours there was a temp warning at about 60 hours in the ecu which a mechanic reset for me last year
    Hey HDAV! Probably is the sensor! Sometimes it is really easy to spot if it has gone bad, there's a silicone type glue on top of the sensor, If you notice the silicone has peeled off a bit, then you will need to replace the sensor, or second option..Must measure resistance of the sensor..you ride in salt water?

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Complete list of engine codes?
    By J-ME in forum Yamaha How To & FAQs
    Replies: 4
    Last Post: 12-04-2006, 05:58 PM
  2. Error ENGINE code P1116
    By sr71bb in forum 4-Tec Performance
    Replies: 2
    Last Post: 08-15-2006, 09:13 PM
  3. YAMAHA Engine Codes
    By Knr in forum Yamaha How To & FAQs
    Replies: 1
    Last Post: 05-23-2006, 08:16 AM
  4. Engine code 15 ?
    By Ronn25 in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 05-19-2006, 11:38 PM
  5. Engine code 1202. So now what?
    By 01xdime in forum 4-Tec Performance
    Replies: 4
    Last Post: 08-19-2005, 07:07 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •