Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1
    xray328's Avatar
    Join Date
    Aug 2011
    Location
    Shorewood, IL
    Posts
    364
    +1
    6

    1200XLT hydroturf question...

    Click image for larger version. 

Name:	ImageUploadedByTapatalk1334014058.865570.jpg 
Views:	56 
Size:	52.5 KB 
ID:	268473

    There's obviously a gap between the rear two pieces. With the bumper back in place that leaves a gap there, looks like a filler piece should go there. Is everyone else's like that or am I missing a piece? I haven't riveted the trim piece down yet, just checking before I do.

    Thanks.


  2. #2
    xray328's Avatar
    Join Date
    Aug 2011
    Location
    Shorewood, IL
    Posts
    364
    +1
    6
    Just to clarify I'm talking about the gap between the hull and the trim piece not between the pieces of mat.

  3. #3
    DarkCanuck's Avatar
    Join Date
    Nov 2010
    Location
    Canada
    Posts
    315
    +1
    17
    Same for me I did mine last year and I never had another piece...

  4. #4

    Join Date
    Aug 2006
    Location
    Indiana
    Posts
    1,274
    +1
    81
    I put a bead of RTV in there after I reattached the rear bumper, in your case maybe black?? I used white since I had light grey hydroturf.

  5. #5
    xray328's Avatar
    Join Date
    Aug 2011
    Location
    Shorewood, IL
    Posts
    364
    +1
    6
    Click image for larger version. 

Name:	ImageUploadedByTapatalk1334025989.714304.jpg 
Views:	42 
Size:	73.4 KB 
ID:	268527

    Seems like an oversight on their part. I thought about the RTV, that's what I use to cover the rivets with, but I didn't know if it would have some strange reaction with the foam...wouldn't that be my luck. The very bottom of the two rear pieces ended up being a 1/2 inch or so too long, so because I had to cut it anyway I just used the extra to bridge the gap.

  6. #6
    60% of the time, it works every time.
    Join Date
    Oct 2009
    Location
    Green Cove Springs Florida
    Posts
    508
    Xray328: got any more pics of the complete install? Was looloking at same pattern for my ski.

  7. #7
    xray328's Avatar
    Join Date
    Aug 2011
    Location
    Shorewood, IL
    Posts
    364
    +1
    6
    Quote Originally Posted by upgraded View Post
    Xray328: got any more pics of the complete install? Was looloking at same pattern for my ski.
    I'll have them for you tonight.

  8. #8
    xray328's Avatar
    Join Date
    Aug 2011
    Location
    Shorewood, IL
    Posts
    364
    +1
    6
    Click image for larger version. 

Name:	ImageUploadedByTapatalk1334100237.775368.jpg 
Views:	45 
Size:	85.0 KB 
ID:	268564Click image for larger version. 

Name:	ImageUploadedByTapatalk1334100255.838932.jpg 
Views:	42 
Size:	68.0 KB 
ID:	268565Click image for larger version. 

Name:	ImageUploadedByTapatalk1334100274.850086.jpg 
Views:	48 
Size:	67.6 KB 
ID:	268566

  9. #9
    Diznasty's Avatar
    Join Date
    Jul 2011
    Location
    ERIE-sistable
    Posts
    140
    xray, do you have any pics of how you took the rear bumper off? I'm redoing mine and saving the rear platform for last. There are two rivets which are visible but then there appears to be two rivets under the bumper? I dont want to start drilling the two visible ones out until i know how to get to the two underneath. Got any pics or tips?

  10. #10
    xray328's Avatar
    Join Date
    Aug 2011
    Location
    Shorewood, IL
    Posts
    364
    +1
    6
    Two corner pieces come off first. There's three rivets I believe that hold each of those on. Once those are off you're left with just the center piece. There's a trim piece that slides out of the center of it which is only removable once the side pieces are off. It just slides in a groove and should come right out. Once that trim piece is out you'll see three or four more rivets, drill those out. Then the only thing holding it on is some foam tape. Gently pull on the piece and the tape should give pretty easy. Clean all that old adhesive off and you're good to go. The new kit should have the replacement rivets. I drilled a couple of the rivets out and had a bigger hole than when I started, so I just used a bolt washer and nut on those areas to reattach the trim piece. I then covered the bolts/rivets with black rtv.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Hydroturf install question
    By Diznasty in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 05-06-2012, 07:35 PM
  2. HydroTurf Question
    By Piney in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 04-14-2012, 12:42 AM
  3. Prop Question,.. again. 2001 1200XLT
    By eurokidlt in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 03-17-2010, 03:16 PM
  4. 2001 1200XLT D Plate install questions from a Rookie
    By kcfunk in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 07-01-2008, 09:53 AM
  5. basic pump questions - '01 1200XLT
    By Jolly Roger in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 07-02-2007, 03:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •