Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
  1. #1

    Join Date
    Jun 2010
    Location
    Atlanta GA
    Posts
    134

    what is this for

    What is this rubber tube for, #19? I bought a non running XLT1200 and this tube was split down the middle and taped on is this common and will it work or should I go through the trouble of replacing it?Click image for larger version. 

Name:	Image.jpg 
Views:	118 
Size:	33.4 KB 
ID:	268703 How hard is it to replace?


  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    You need to replace it or you will sink.

  3. #3

    Join Date
    Jun 2010
    Location
    Atlanta GA
    Posts
    134
    The original problem was a clogged cat. I kinda want to see if it runs and preforms before I dig much deeper and spend more money. It was obviously working like this before. Is it under pressure?

  4. #4
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Yes its wide open to the pump tunnel.
    Quote Originally Posted by beanutputter View Post
    The original problem was a clogged cat. I kinda want to see if it runs and preforms before I dig much deeper and spend more money. It was obviously working like this before. Is it under pressure?

  5. #5
    Definetly don't put it in the water.....or if you really wanna see if it runs just put the back end in the water and leave it on the trailer, but you are still going to take on a bit of water...I don't see how you could run it without that tube and my guess is someone salvaged parts from it

  6. #6
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,800
    +1
    449
    it probably sunk already

    that hose is common to split on that model

    I have the heavy duty replacement hose in stock

  7. #7

    Join Date
    Jun 2010
    Location
    Atlanta GA
    Posts
    134
    Is it a pain in the butt to change? do I have to pull the motor or do I do it from the Jet Pump end? If I have to pull the whole motor, I will probably just state parting it out.

  8. #8
    rangermtb5's Avatar
    Join Date
    Apr 2008
    Location
    North Jersey
    Posts
    4,473
    +1
    58
    Quote Originally Posted by beanutputter View Post
    Is it a pain in the butt to change? do I have to pull the motor or do I do it from the Jet Pump end? If I have to pull the whole motor, I will probably just state parting it out.
    pull the pump, slide the new WFO hose on, clamp it down, done!

  9. #9
    rangermtb5's Avatar
    Join Date
    Apr 2008
    Location
    North Jersey
    Posts
    4,473
    +1
    58
    It was actually taped together?! do you have a picture of this?

  10. #10

    Join Date
    Jun 2010
    Location
    Atlanta GA
    Posts
    134
    No pic. I already cut it off. As you can imagine it looked pretty suspicious.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. STXR Exhaust Fitting!?! what is this for???
    By Jamescmei in forum Kawasaki PWC Performance (2-stroke)
    Replies: 25
    Last Post: 10-18-2017, 05:43 AM
  2. What is this for?
    By oodaeSGuy in forum Sea Doo Spark
    Replies: 1
    Last Post: 07-28-2015, 03:14 PM
  3. What is this "clip" for? 98 GP1200
    By krispaintballz in forum Yamaha Old School Skis
    Replies: 9
    Last Post: 01-10-2008, 02:56 PM
  4. What Polaris is this for?
    By mdeps in forum Polaris Open Discussion
    Replies: 4
    Last Post: 05-24-2007, 12:34 AM
  5. What is this for
    By brad2510 in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 05-08-2006, 08:55 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •