Results 1 to 6 of 6
  1. #1

    2006 RXP starting problems...help!

    My 2006 RXP has good battery and new starter solanoid and DESS post. When I put key on and the instrumentation board comes on but no beep and a constant clicking (click, click, click) from the starter solanoid when I push the start button. The engine will not turn over. Any ideas? The buzzer does work when I connect it straight to the battery. Thanks for the help!


  2. #2
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,625
    +1
    806
    Quote Originally Posted by sryan View Post
    My 2006 RXP has good battery and new starter solanoid and DESS post. When I put key on and the instrumentation board comes on but no beep and a constant clicking (click, click, click) from the starter solanoid when I push the start button. The engine will not turn over. Any ideas? The buzzer does work when I connect it straight to the battery. Thanks for the help!
    I would start by checking for a blown fuse

  3. #3
    Kiwi spanner handler
    Join Date
    Dec 2007
    Location
    Christchurch NewZealand
    Posts
    579
    +1
    13
    the click click is usually low voltage so either the battery is faulty or the cables/terminal connections are bad. you need to test with a multi meter

  4. #4
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Quote Originally Posted by jasonze View Post
    the click click is usually low voltage so either the battery is faulty or the cables/terminal connections are bad. you need to test with a multi meter

    +1 and i would make sure the starter is good also....if it took on water and has sat it may have gone bad...

  5. #5
    richrxp's Avatar
    Join Date
    Jun 2006
    Location
    Netherlands
    Posts
    949
    +1
    1
    New batterys also fail,had this happen to me a few times.
    You can put a screwdriver on the starter solenoid and start your engine.
    If this happens your solenoid is bad.
    I think it's your battery.

  6. #6
    Quote Originally Posted by richrxp View Post
    New batterys also fail,had this happen to me a few times.
    You can put a screwdriver on the starter solenoid and start your engine.
    If this happens your solenoid is bad.
    I think it's your battery.

    Thanks for all of the suggestions. I will give them a try.

    Stu

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Rxp starting problems. Need your help
    By mbaseball3 in forum 4-Tec Performance
    Replies: 26
    Last Post: 03-25-2009, 01:50 PM
  2. 04 RXP Starting problem
    By GTGRXP in forum 4-Tec Performance
    Replies: 10
    Last Post: 08-06-2007, 07:01 AM
  3. 2006 rxp idling problem
    By turbodiesel in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 07-16-2007, 11:55 PM
  4. 05 RXP Starting problems
    By Cody Townsend in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 05-09-2006, 05:51 PM
  5. 04 RXP Starting problem/question...
    By BLOWNRXP in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 06-01-2005, 10:14 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •