Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 27
  1. #1

    I have the X Charger Curse ... Blew my motor again!

    .
    Last edited by radeon; 05-10-2012 at 02:40 PM.


  2. #2
    Let me clarify, when it hydrolocked i immediately got all of the water out of the top end (mostly rear cyl) and drained the oil out of it, and then filled it back up with cheap walmart stuff, flood clear started it a bit with the shitty oil to circulate it, drained it .... did this again before putting seadoo oil back into it with a new filter.

  3. #3
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    10,073
    +1
    790
    Did pieces of the block go everywhere? Or not? Just not sure as theabove post I believe you mentioned it started?

  4. #4
    Orlando Shark's Avatar
    Join Date
    Mar 2009
    Location
    Miami, FL
    Posts
    2,419
    +1
    10
    When you hydro locked your motor you possibly bent a rod and that is probably what caused your engine damage not your x charger.

  5. #5
    hero's Avatar
    Join Date
    Feb 2011
    Location
    Australia sydney
    Posts
    331
    Quote Originally Posted by Shark View Post
    When you hydro locked your motor you possibly bent a rod and that is probably what caused your engine damage not your x charger.
    +1 was thinking the same thing

  6. #6
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Quote Originally Posted by Shark View Post
    When you hydro locked your motor you possibly bent a rod and that is probably what caused your engine damage not your x charger.
    +2

  7. #7
    dnielsen's Avatar
    Join Date
    May 2008
    Location
    Shreveport, Louisiana
    Posts
    2,018
    +1
    94
    Quote Originally Posted by Shark View Post
    When you hydro locked your motor you possibly bent a rod and that is probably what caused your engine damage not your x charger.
    +3, BENT ROD = BOOM! I swear if I ever hydrolock I wont start it before replacing all the rods!

  8. #8
    formerly Gold06RXP Turbo Nick's Avatar
    Join Date
    May 2007
    Location
    Dayton, OH
    Posts
    2,095
    +1
    97
    +3
    Quote Originally Posted by BigDaddyRXP View Post
    +2

  9. #9
    dnielsen's Avatar
    Join Date
    May 2008
    Location
    Shreveport, Louisiana
    Posts
    2,018
    +1
    94
    Quote Originally Posted by GOLD06RXP View Post
    +3
    Come on man I wuz +3 so you gotta be +4 or I'll take my ball and go home!!!

  10. #10

    Join Date
    Mar 2006
    Posts
    1,833
    +1
    119
    how did the hose pop off the intercooler? Was someone playing with the hoses and swapped out clamps and forgot to tighten them or used cheap clamps or ???

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. My Sick Handlebar Grips. I think I have the best...
    By HallPass in forum Open Discussion
    Replies: 21
    Last Post: 09-24-2009, 07:46 AM
  2. Help- i just blew all of the oil out of my motor
    By pdxrealtor in forum 4-Tec Performance
    Replies: 12
    Last Post: 08-04-2009, 01:37 AM
  3. I blew my Motor
    By kido81 in forum Yamaha Open Discussion
    Replies: 3
    Last Post: 06-02-2009, 06:50 PM
  4. Replies: 7
    Last Post: 12-26-2008, 04:07 PM
  5. I think I blew my motor on my 06 RXP???
    By MVR 155 in forum Sea Doo Open Discussion
    Replies: 16
    Last Post: 06-13-2008, 04:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •