Page 1 of 2 1 2 LastLast
Results 1 to 10 of 19
  1. #1

    stuck at 3500 rpms

    i recently purchased a 1998 seadoo gsx. i got it in the water for the first time today and the rpms are PEGGED at 3500. it starts and idles fine, but if you try to go anywhere it will not go above 3500k. its almost as if something is stuck in the impeller. i have lots of experience with two strokes and outboards, but zero pwc experience. i dont even know where to start. it almost seems like its in some sort of limp mode because the lack of power is so consistent.

    heres a pic of the badboy



    Uploaded with ImageShack.us
    Last edited by octaneforce; 04-16-2012 at 09:05 PM.


  2. #2

  3. #3
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    can you tell if its a fuel related stall or a propulsion related stall? If the engine sounds like its missing or making a chugging sound its time to clean the fuel system. your way lean.

  4. #4
    [QUOTE=airbornexp;1921421]can you tell if its a fuel related stall or a propulsion related stall? If the engine sounds like its missing or making a chugging sound its time to clean the fuel system. your way lean.[/QUOTE
    well out of the water i can pin it and it will spin up to about 7100 rpms. in the water it just chugs at that consistent 3500 HOWEVER once in a while it will shoot up to about 5200rpms and leap out of the water for a split second. its weird. also, when i turn it on the main screen says "MAINT" for a couple seconds. does this thing have a limp mode? like i said, it just starts and idles so nicely and bogs so perfectly, that it doesnt seem like a typical fuel problem. ill tear it down if need be though.

  5. #5

    Join Date
    Mar 2006
    Posts
    1,833
    +1
    119
    sounds like a bad voltage regulator to me, but your machine has other known issues as mentioned about the fuel system.

  6. #6
    SURFnTURF's Avatar
    Join Date
    May 2007
    Location
    Australia
    Posts
    878
    +1
    11
    Sounds like its only running on one cylinder ,can you pull the plugs and see if they are both firing ?

  7. #7
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    Quote Originally Posted by jim View Post
    sounds like a bad voltage regulator to me
    that was going to be my assumption also if the fuel system was verified..

  8. #8
    Quote Originally Posted by jim View Post
    sounds like a bad voltage regulator to me, but your machine has other known issues as mentioned about the fuel system.
    the whole time i was using it the screen said "12v low" however my battery is fairly new and i keep it on a maintainer. where is the voltage regulator? how does it affect the way the engine runs? thanks

  9. #9
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    its in the front gray box. split it open and its the little square with yellow and red wires coming out of it.

  10. #10
    tweeker's Avatar
    Join Date
    Jul 2007
    Location
    Denver NC
    Posts
    706
    +1
    45
    Quote Originally Posted by airbornexp View Post
    its in the front gray box. split it open and its the little square with yellow and red wires coming out of it.
    That rectifier is mounted on the mpem up front on the 97 take a volt meter and check the charging system with the engine running at 3500 rpm you should see a gross overcharging like 16 plus volts

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Polaris '99 Genesis stuck at 4800 RPM
    By timeoff in forum Polaris Open Discussion
    Replies: 1
    Last Post: 08-25-2012, 10:13 PM
  2. gp1300 stuck at 5000 rpm
    By Binihana in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 08-25-2011, 06:11 AM
  3. 05 RXp stuck at 7500 rpm
    By Boosted3s in forum 4-Tec Performance
    Replies: 41
    Last Post: 06-23-2011, 09:54 AM
  4. 250x hesitating at [email protected]
    By Elityler in forum Kawasaki PWC Performance (4-stroke)
    Replies: 30
    Last Post: 04-19-2011, 08:43 PM
  5. Stuck at 6000 RPM's
    By Aldoe in forum Yamaha How To & FAQs
    Replies: 2
    Last Post: 05-29-2010, 05:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •