Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22
  1. #1

    Question 2005 rxt fault codes

    Have a 2005 rxt. Just installed an 08 scic 215hp engine in the ski. Changed oil seperator from 08 to 05 on front of engine. Installed 05 valve cover with nipple on it for the vent hose. Removed 420856500 vent valve from rear of 08 head and installed cap/plug from the 05. Had no key so had 2 keys programmed for original ECM. Getting fault codes P1502 (TOPS funtional problem) and P0520 (oil pressure switch funtional problem). Checked TOPS valve per book Resistance 1.4 OHMS and can hear valve operating. Seems to be in limp home mode runs 35mph @5000rpm red light flashing. Can anyone help?


  2. #2

    Join Date
    Jun 2009
    Location
    Tierra Verde, Florida, United States
    Posts
    911
    +1
    17
    Do you have a 05 oil pressure switch on the motor or is it the 08? If it's the 08 I think you will need to change to the older one. The old switches work backwards from the new ones one type grounds the wire until there is oil pressure the other type grounds the wire when pressure builds up.

  3. #3
    thanks Joe. i have the 08 sensor in it. they do have different part numbers. will get an 05 and give it a shot. any idea on the TOPS valve?

  4. #4
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    1+ on the oil pressure switch the pre 06 uses a normally open switch and the 06+ uses a normally closed switch. As for the tops make sure you have the correct plug on the pressure switch it should be the single wire plug. Item #9 is the single wire plug.


  5. #5
    By the wiring diagram i have it shows the TOPS valve has a 2 wire connector. Purple/grey and Brown/white. Is this correct?

  6. #6

    Join Date
    Jun 2009
    Location
    Tierra Verde, Florida, United States
    Posts
    911
    +1
    17
    did you change your presser switch yet? On the TOPS I thinks it's a one wire also

  7. #7
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Im referring to the OIL SEPARATOR PRESSURE
    SENSOR (OSPS) as the single wire plug BL/RE
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	2005 Sea-Doo Engine Service Manual.jpg 
Views:	936 
Size:	81.0 KB 
ID:	269074  

  8. #8
    waiting on the switch to arrive.

  9. #9
    that is correct. the osps has a single wire connector with a bl/red wire.

  10. #10
    joe, got the new oil pressure switch in and it cleared that code. put it in the water and still in limp home mode and get the p1502(Tops functional problem code). also p0113 (intake manifold temp sensor shorted to 12v or open circuit code) when engine is running only. any ideas?








    0

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2006 rxt fault code issues
    By Chasing_the_Sun in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 09-09-2016, 03:58 PM
  2. 2007 RXT fault code 1502 help
    By dustintinsley in forum 4-Tec Performance
    Replies: 9
    Last Post: 07-05-2014, 07:42 PM
  3. seadoo rxt , 2005 , p1202 fault code
    By pausanandrei in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 08-24-2011, 12:19 AM
  4. rxt , 2005 , p1202 fault code
    By pausanandrei in forum 4-Tec Performance
    Replies: 0
    Last Post: 08-19-2011, 02:00 PM
  5. RXT IS 255 Fault Code P0340????????
    By asia517 in forum 4-Tec Performance
    Replies: 1
    Last Post: 10-12-2009, 09:22 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •