Results 1 to 5 of 5
  1. #1
    skigolfnut's Avatar
    Join Date
    Jun 2009
    Location
    League City TX
    Posts
    1,979
    +1
    33

    06-rxp test this weekend

    I took the RXP out this weekend to test the new Rotax racing ecu and the new Supertech valve springs, I let it warm up real good, then I noticed the afr's were a little rich up at the 7000 rpm range, so I took off the rising rate hose and plugged hole, they were still a little high so I dialed down the fuel pressure on the pressure regulator, it seemed to be at 12.5 to 13.5 thru all the range but I could not get above 8100 rpms, the water was kind of choppy and I could tell I was bouncing a little bit, I could not find a smooth spot,
    I hooked the rising rate hose back up, and adjusted the fuel pressure regulator and it seemed to be dead on 12.2 across all rpms and I could get it up to 8300,
    I am running an untouched 15/20 right now,
    I let it cool down, the warmed it up real good, then did some practice starts and buoy turns, the ET-137 was awesome on the buoy turns with that Rotax ecu, just a slight off throttle to initiate the turn then I could power thru it nicely,
    I don't know if this stock fuel pump can handle all the fuel this thing needs now, or not?
    It kind of felt like I was getting supercharger slip when the ski would kind of come unhooked which is normal, but it felt like I should be getting more?
    any ideas?


  2. #2
    83.0 @ 8400 jhill19's Avatar
    Join Date
    Jul 2010
    Location
    Teays Valley, West Virginia
    Posts
    2,800
    +1
    81
    Wouldn't hurt to pull the s/c and check the slip, I need to do that on mine. Slow91 has walbro fuel pumps for around 85.00. What's the rev limiter with your rotax?

  3. #3
    skigolfnut's Avatar
    Join Date
    Jun 2009
    Location
    League City TX
    Posts
    1,979
    +1
    33
    it is supposed to be 8650
    I have less that 8 hours on a new et-137 install with new mcmaster washers and shim with the slip set pretty high,
    Slow91 said they were 95 shiipped

  4. #4
    83.0 @ 8400 jhill19's Avatar
    Join Date
    Jul 2010
    Location
    Teays Valley, West Virginia
    Posts
    2,800
    +1
    81
    Quote Originally Posted by skigolfnut View Post
    it is supposed to be 8650
    I have less that 8 hours on a new et-137 install with new mcmaster washers and shim with the slip set pretty high,
    Slow91 said they were 95 shiipped
    Must have gone up since I bought mine.

  5. #5
    skigolfnut's Avatar
    Join Date
    Jun 2009
    Location
    League City TX
    Posts
    1,979
    +1
    33
    I stand corrected I looked at the old post from the guy I bought it from and it is 8600 rpms mapped for 42's
    do you think the stock fuel pump can not keep up with the duty cycle?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXP 300 testing 4 blade 161mm solas this weekend
    By WICKEDSEADOO in forum 4-Tec Performance
    Replies: 53
    Last Post: 08-23-2016, 11:36 AM
  2. Region 8 Race This weekend, May 21, 06 - mitch411RXP
    By ramnj in forum Race Events and News
    Replies: 5
    Last Post: 05-21-2006, 10:15 PM
  3. saw alot of rxp's this weekend
    By godfather in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 04-24-2006, 03:39 PM
  4. I saw a new rxp owner this weekend.
    By MikeTrin in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 08-08-2005, 06:18 PM
  5. Got my rxp to 79 this weekend!
    By MikeTrin in forum 4-Tec Performance
    Replies: 13
    Last Post: 05-10-2005, 03:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •