Results 1 to 5 of 5
  1. #1
    Impulses's Avatar
    Join Date
    Dec 2011
    Location
    europe
    Posts
    822
    +1
    27

    Question Hello everyone, 15 hours with RXT X 260 RS observations

    hello all,I will tell youwhat I experiencedafterowning aRXTX 260RS2011 model,after 13hours andmaketimelyRevison10 hours, Idecided to installat the dealershipa water pumpand thedepth gaugeoriginalsea doo.The fact isthat with 14hours of useand afterlunch ata portwith my partner, the bikeNOT START!

    Whatwas myfrustrationthat I could notcallanyone orgo getthe car withthe carsince thatday we wentalone anddecided to doa long routeaproximadamente.Tras45 milesan hour of waitingthe bikedecidestostart again....what my partnerand I decided tomake usback tothe seaback toport.Aftersuccessfullynavigating32 milesanda jumptothe bikeagain in the middleof the sea,withahookedneedleat 7,000rpmand the other at40 miles.This timein the middleof the seawithout shipsin sightat asignificantdistance from the coastandno other company thanthat of fish, havingresignedto waitanother hour or sothe bikedecides toboot, soI putbackfinally arrivingto the portthe same....

    Aftersweeteningthe bikeand storethe next daytook her to thedealerwhereI boughtoficalBRPandafter puttingthepcfind that thefailureis caused by arelayfuse box.

    Here is where my fear, I fear that may happen again at any time, so you would beg mewith your experiences ayudarais solucioner to this problem in a definitive form so we cango sailing with confidence.

    Thank you very much and greetings.



  2. #2
    Impulses's Avatar
    Join Date
    Dec 2011
    Location
    europe
    Posts
    822
    +1
    27
    No one else has had this problem with the relays?

  3. #3
    MTL Bimmer's Avatar
    Join Date
    May 2010
    Location
    Montreal, QC & State Of Kuwait
    Posts
    52
    Quote Originally Posted by Impulses View Post
    No one else has had this problem with the relays?
    I dont thinkanyone is willingtoread something likethis! lol

  4. #4
    Is it a bird? Is it a plane? RXPX's Avatar
    Join Date
    Jan 2012
    Location
    Gold Coast, QLD, Australia
    Posts
    336
    damn, i have a headache from trying to read that. If its from salt water getting in just clean it out, replace the fuses, spray some lube and cable tie the thing shut tight.

    andpleaseusespacesinfuturewhereappropriate

  5. #5
    Impulses's Avatar
    Join Date
    Dec 2011
    Location
    europe
    Posts
    822
    +1
    27
    conclusion that I am the first case before it breaks the relay, good time is in the shop, when you know something else I comment the final solution.

    But as strange .. I have not gone before anyone ...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Rxt X 260 rs with Riva stage 4 motor failed
    By Redrockat in forum 4-Tec Performance
    Replies: 54
    Last Post: 11-03-2015, 08:24 PM
  2. Cleaned my intercooler at 15 hours with a 1/2 gal gas reset BOV to 2.5 threads
    By rod_rod in forum Kawasaki PWC Performance (4-stroke)
    Replies: 10
    Last Post: 08-24-2015, 01:11 AM
  3. Anybody else with this in there 2011 RXT-X 260 RS?
    By jumpman in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 02-28-2014, 03:43 PM
  4. Problem with RXT-X 260 buttons
    By RSTurbo in forum 4-Tec Performance
    Replies: 2
    Last Post: 02-07-2011, 05:12 PM
  5. Problem with rxt-x 260 or something else
    By rxp1972 in forum 4-Tec Performance
    Replies: 9
    Last Post: 07-20-2010, 11:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •