Results 1 to 4 of 4
  1. #1
    83Gator's Avatar
    Join Date
    Jul 2008
    St. Amant, LA

    What I'm working on...

    I'm not sure if my J Pipe/Waterbox/Mani Cooling Lines are assembled in the correct orientation? Does this configuration look right to you guys

    J/K I saw this heap of an engine sitting on a work bench during Saturday's ride and I had to take a pic. Damn shame it's too big for any of the current hulls - it'd make quite a conversion...
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	P1170710.jpg 
Views:	227 
Size:	112.7 KB 
ID:	268986  

  2. #2
    A little creativity and you can make anything happen

  3. #3
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Nederland, Texas

  4. #4
    Jarrett's Avatar
    Join Date
    Apr 2005
    Waxahachie, TX

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. What are u working on?
    By hungoverracer in forum Midsouth
    Replies: 144
    Last Post: 06-30-2012, 11:20 PM
  2. o.p.a.s not working
    By john2008 in forum 4-Tec Performance
    Replies: 16
    Last Post: 08-26-2011, 10:52 PM
  3. # fx_shos need working on
    By lafitteboy in forum Yamaha Open Discussion
    Replies: 5
    Last Post: 06-15-2010, 12:22 PM
  4. Trim not working
    By bradders25 in forum Polaris Open Discussion
    Replies: 14
    Last Post: 08-05-2008, 08:45 AM
  5. Engine not working I
    By Fabian_1 in forum Yamaha How To & FAQs
    Replies: 4
    Last Post: 01-21-2008, 07:06 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts