Results 1 to 7 of 7
  1. #1

    IBR Bucket Malfunction.... Please help

    So, today I'm riding and I hit the brake to stop.... I got nothing, ski didn't slow down at all. Then I started the ski later thinking nothing of it and started to ride. All of a sudden the ski wouldn't move. I Keep the key in to keep the ski runing and reach under and lift the bucket up. It lifted rather weakly w/o much resistance. It basically stayed up but felt like it could fall into reverse easily. I rode around and a little while later it fell on its own. I had to manually lift it regularly. Any help is appreciated. Thanks


  2. #2
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Sounds like something broke.
    Pics of the rear of the ski might help.

  3. #3
    Is it a bird? Is it a plane? RXPX's Avatar
    Join Date
    Jan 2012
    Location
    Gold Coast, QLD, Australia
    Posts
    336
    I believe the IBR has an inbuilt plastic weak point somewhere on the lifting mechanism to protect the rest of the parts. I'd say its snapped, look for any bits of plastic in there that look broken, you may just need to replace one little piece.

  4. #4
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    NJ
    Posts
    7,994
    +1
    455
    Did you change the prop recently? Glance over the ibr as me mentioned above and verify everything is secure

  5. #5
    moultrie rxp's Avatar
    Join Date
    Jul 2006
    Location
    South Carolina
    Posts
    172
    +1
    3
    There is 2 plastic linkage arms (part # 268000042) that has been known to break if you hit something on the reverse bucket. It does not have to be on the water for it to happen it could happen while moving the ski around in the garage. If it was electrical and the reverse bucket was not functioning the ski would go into the limp mode. I keep a spare in my tool box they are not expensive.

  6. #6
    Quote Originally Posted by moultrie rxp View Post
    There is 2 plastic linkage arms (part # 268000042) that has been known to break if you hit something on the reverse bucket. It does not have to be on the water for it to happen it could happen while moving the ski around in the garage. If it was electrical and the reverse buket was not functioning the ski would go into the limp mode. I keep a spare in my tool box they are not expensive.
    Thanks guys much appreciated......

  7. #7
    pass1's Avatar
    Join Date
    Apr 2009
    Location
    Gatineau, Canada
    Posts
    423
    +1
    5
    Lots of my friends had same problem, it ended up that the ecu needed reprogramming.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Please help need bucket parts or assembly near toms river nj
    By Titan_Joe in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-05-2015, 07:23 AM
  2. iBR issue, please HELP
    By Tom9960 in forum 4-Tec Performance
    Replies: 7
    Last Post: 07-23-2014, 06:31 PM
  3. My LCD Screen Malfunctioning 2011 RXTX. Please Help!!!
    By coachfarnen in forum 4-Tec Performance
    Replies: 7
    Last Post: 08-21-2013, 10:59 AM
  4. CHEWED UP SOME ROPE TODAY PLEASE HELP
    By PAINKILLER in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 07-07-2005, 02:14 PM
  5. PLEASE HELP MUSIC DOWNLOADING
    By CRAZEDRXP in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 07-05-2005, 09:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •