Results 1 to 7 of 7
  1. #1
    NastyStang's Avatar
    Join Date
    Jun 2009
    Location
    Central Florida
    Posts
    156
    +1
    3

    2007 RXT Key Problem

    I've got a 2007 RXT that has been having trouble starting lately.

    I get the normal beep when the key is attached to the post. Although when I go to start it I get nothing. No crank, nothing. Just like the key wasn't on it. I'll end up wiggling the key on the post or removing it and putting it back on and it will start fine.

    Is this common? What is the fix?


  2. #2
    NastyStang's Avatar
    Join Date
    Jun 2009
    Location
    Central Florida
    Posts
    156
    +1
    3
    Bump.

  3. #3
    NastyStang's Avatar
    Join Date
    Jun 2009
    Location
    Central Florida
    Posts
    156
    +1
    3
    No one?

  4. #4

    Join Date
    Apr 2012
    Location
    Vancouver, Washington
    Posts
    80
    I have a ski that is finnicky about the key also. It's hard to push on and I often have to take it back off and try again before I get the 'beep, beep.' But it's been that way since I bought it new. My other ski is not as problematic. But you say "having trouble starting lately" which implies it started fine and now it doesn't. Not sure how to help you with that.

  5. #5
    NastyStang's Avatar
    Join Date
    Jun 2009
    Location
    Central Florida
    Posts
    156
    +1
    3
    Quote Originally Posted by Steven63 View Post
    I have a ski that is finnicky about the key also. It's hard to push on and I often have to take it back off and try again before I get the 'beep, beep.' But it's been that way since I bought it new. My other ski is not as problematic. But you say "having trouble starting lately" which implies it started fine and now it doesn't. Not sure how to help you with that.
    When I said having trouble starting lately I meant by using the key.

  6. #6

    Join Date
    Apr 2012
    Location
    Vancouver, Washington
    Posts
    80
    Yeah I knew what you meant, but I meant I wasn't sure why it would be fine and then out of the blue you'd start having trouble with it. That sounds like something is worn out, which is different than my ski just being finnicky.

  7. #7
    AndinoWatercraft's Avatar
    Join Date
    Feb 2008
    Location
    Puerto Rico
    Posts
    306
    +1
    4
    Some models have like a delay box installed for those times the key gets put in the DESS and the rider isn't starting the Doo right away. Check your battery voltage. Maybe a drop down test. Also can check your starter relay or the start button. On those models the button can get hard to push or make contact due the desing of the button housing.

    Hope this helps

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. SOLD ECU; Stock 2007 RXT ECU with keys
    By gbayus in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 05-14-2014, 12:16 PM
  2. SOLD ECU; Stock 2007 RXT ECU with keys
    By gbayus in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 05-14-2014, 12:09 PM
  3. 2007 rxt hood piston problem
    By Uncleterry in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 08-07-2013, 04:07 PM
  4. Replies: 2
    Last Post: 06-29-2011, 09:27 PM
  5. 2010 RXT-X key problem
    By Phil in forum 4-Tec Performance
    Replies: 39
    Last Post: 09-16-2010, 02:46 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •