Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15

Thread: Mph Loss

  1. #1
    Mi410's Avatar
    Join Date
    Apr 2012
    Location
    Maryland
    Posts
    25

    Mph Loss

    From what I have been reading the stock rpm for a rxp is about 8100-8200. My 2005 rxp is hitting 6 on glass with the rpm hitting 8150.... Why am I losing 6 mph!!!??????


  2. #2
    Mi410's Avatar
    Join Date
    Apr 2012
    Location
    Maryland
    Posts
    25
    Btw I have 48 hours

  3. #3
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Quote Originally Posted by Mi410 View Post
    From what I have been reading the stock rpm for a rxp is about 8100-8200. My 2005 rxp is hitting 6 on glass with the rpm hitting 8150.... Why am I losing 6 mph!!!??????
    Your only going 6 mph?

  4. #4
    Mi410's Avatar
    Join Date
    Apr 2012
    Location
    Maryland
    Posts
    25
    64 whoops haha

  5. #5
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    What mods?
    Stock ski you should be around 67-68.

  6. #6
    SPEED COMES 1/10 @ A TIME SpeedFreeks Racing's Avatar
    Join Date
    Jun 2007
    Location
    BROOKLYN N.Y.
    Posts
    407
    +1
    1

    limiter

    Quote Originally Posted by Mi410 View Post
    From what I have been reading the stock rpm for a rxp is about 8100-8200. My 2005 rxp is hitting 6 on glass with the rpm hitting 8150.... Why am I losing 6 mph!!!??????
    it is very possable that you can be on the rev limiter and your tach is showing 8150 i would take the skis out for a ride hold the throttle wide open and slowly let off very little at a time and see if the rpm drops right away..... if your rpm drops right away your not on the limiter and you need to look else where.

    check this link out: http://www.greenhulk.net/forums/showthread.php?t=173968

  7. #7
    Mi410's Avatar
    Join Date
    Apr 2012
    Location
    Maryland
    Posts
    25
    Quote Originally Posted by SpeedFreeks Racing View Post
    it is very possable that you can be on the rev limiter and your tach is showing 8150 i would take the skis out for a ride hold the throttle wide open and slowly let off very little at a time and see if the rpm drops right away..... if your rpm drops right away your not on the limiter and you need to look else where.

    check this link out: http://www.greenhulk.net/forums/showthread.php?t=173968

    I really want to give this a shot! thanks for help on this one. I was really disappointed in the mph loss, I was racing my buddy who has the rxt-x 255 and he crushed me yesterday. 4 days ago we were pretty much neck and neck i had no idea what happend.

  8. #8
    SPEED COMES 1/10 @ A TIME SpeedFreeks Racing's Avatar
    Join Date
    Jun 2007
    Location
    BROOKLYN N.Y.
    Posts
    407
    +1
    1
    Quote Originally Posted by Mi410 View Post
    I really want to give this a shot! thanks for help on this one. I was really disappointed in the mph loss, I was racing my buddy who has the rxt-x 255 and he crushed me yesterday. 4 days ago we were pretty much neck and neck i had no idea what happend.
    well now that your saying your ski was running good 4 days ago and now it's not you may have some kind of other problem. it may still be somthing with your prop.... like some kind of rock damage or a bad wear-ring. also check your pump shoe to see if it may be cracked just above where your intake grate bolt's in to your ride plate.

    i have also seen plastic bags or fishing string wrapped around the drive shaft causing that same kind of problem..... loss of speed with no loss in rpm.

  9. #9
    Mi410's Avatar
    Join Date
    Apr 2012
    Location
    Maryland
    Posts
    25
    Thanks for all the help when i get home im gonna check all that out. The trim doesnt effect the speed that much? i need to go take it in for the BUDS hook up. The person i bought the ski from didnt take good care of it so im trying to get everything ship shape

  10. #10
    12timeworldchamps's Avatar
    Join Date
    Feb 2006
    Location
    Maryland
    Posts
    445
    +1
    9
    Welcome to the board. Yes, trim does impact speed. Two (2) clicks above neutral seems to be the sweet spot on that machine. Where in MD do you ride?

    Ed

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2004 RXP MPH Loss HELP!!!.
    By seadawg in forum 4-Tec Performance
    Replies: 1
    Last Post: 07-20-2010, 09:16 PM
  2. depitch impeller loss top end speed 1 mph
    By thomas loh in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-09-2010, 02:58 PM
  3. '03 GTX SC - Loss of RPM's and MPH...CEL on
    By jb83 in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 05-19-2009, 02:42 PM
  4. Replies: 6
    Last Post: 07-06-2008, 09:48 PM
  5. 600 RPM and 5 mph Loss?
    By Red Devil in forum 4-Tec Performance
    Replies: 30
    Last Post: 07-28-2005, 09:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •