Results 1 to 8 of 8

Thread: Dead GTX Ltd?

  1. #1

    Dead GTX Ltd?

    I have a 2011 GTX Ltd that i just took out of winter storage, when i wanted to start it nothing happned when i pressed the start-stop button.
    I checked the battery and it was a little low at 12,3V so i put a charger on it for a couple of hours and now it was at 13V so that should not be a problem.
    I have also checked all the fuses and the relay in the fusebox but everything checks out but the ski is completely dead.
    Do you guys have any idea about what is going on here?


  2. #2
    rangermtb5's Avatar
    Join Date
    Apr 2008
    Location
    North Jersey
    Posts
    4,473
    +1
    58
    Did the gauges Power up? Did it recognize your key?

  3. #3
    No gauges no fuel pump no nothing, it is completely dead..

  4. #4
    rangermtb5's Avatar
    Join Date
    Apr 2008
    Location
    North Jersey
    Posts
    4,473
    +1
    58
    Do you have another key? If so try that.

  5. #5
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    im thinking that you have a blown fuse

  6. #6
    JT jpt7779's Avatar
    Join Date
    Jul 2008
    Location
    Pittsburg, Texas Lake Bob Sandlin
    Posts
    3,851
    +1
    742
    I would try a different battery first. Just because the voltage is 12v doesn't mean there is enough cranking amps to bring it to life. Next check the appropriate fuzes. Next DESS post and key.

  7. #7
    Found the problem, the start-stop switch is not working new one ordered.

  8. #8
    If it was the start stop switch, then why didn't the ski recognize the key?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 06 Gtx Ltd
    By texas swede in forum 4-Tec Performance
    Replies: 11
    Last Post: 07-08-2006, 10:05 PM
  2. 05 gtx ltd
    By bigdeez in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-08-2006, 05:01 PM
  3. XSPower IC...for a 2004 GTX LTD...
    By Totallyblown in forum 4-Tec Performance
    Replies: 6
    Last Post: 04-09-2006, 09:58 AM
  4. question about my 05 gtx ltd.
    By chazavw in forum 4-Tec Performance
    Replies: 15
    Last Post: 12-02-2005, 02:44 PM
  5. 2005 seadoo gtx ltd
    By jetskibill9999 in forum 4-Tec Performance
    Replies: 2
    Last Post: 10-17-2005, 06:58 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •