Results 1 to 5 of 5
  1. #1

    Odd noise from rear of ski

    I am not sure how to explain this, this is what happened. I was ridding my ski and idling out of the 5, once i was leaving the 5 it seemed low on power. I let off and the motor died. I started it back up and heard a thump and regained power. I pulled the seat to check for water, everything seemed fine. I loaded it back on the trailer and started it to blow the water out of the exhaust and heard a rattling. I have pulled the nozzle of the jet, everything looks fine. Any ideas?

    Sorry for the long post.

    2006 RXP sc ic


  2. #2
    icdoo's Avatar
    Join Date
    Feb 2011
    Location
    Iowa
    Posts
    381
    +1
    23
    Chunk of debris maybe lodged in the pump and then let go? They all rattle when not in the water.

  3. #3
    I'm guessing some debris too

  4. #4
    I was thinking the same thing. I thought since I have gone as far as I have in the tear down I would check the impeller bearing and wear ring clearance. Does anyone know what size hex wrench for the impeller bolt?

  5. #5
    warner0308's Avatar
    Join Date
    Apr 2011
    Location
    mchenry,il.
    Posts
    519
    +1
    3
    i think its 12mm, auto zone has them in a three pack variuos sizes for 17 bucks

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Loud Vibration/Rattle from Rear of STX15
    By SCHNORR12 in forum Kawasaki How To & FAQs
    Replies: 10
    Last Post: 10-03-2017, 09:26 PM
  2. 2005 rxp grinding noise from back of ski help plz
    By Pikerx in forum 4-Tec Performance
    Replies: 7
    Last Post: 07-23-2016, 04:26 PM
  3. 2015 FZS rattle noise from front of engine
    By BLASTER 1 in forum Yamaha PWC Performance (4-stroke)
    Replies: 11
    Last Post: 07-13-2015, 06:48 PM
  4. Vibration from rear of ski BUT comes and go's?!
    By JohnBoyMinster in forum Kawasaki PWC Performance (2-stroke)
    Replies: 5
    Last Post: 06-15-2015, 08:56 PM
  5. Removing Pump from rear of 95 sl 750
    By sweetcoupe in forum Polaris Open Discussion
    Replies: 9
    Last Post: 06-12-2007, 11:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •