Results 1 to 3 of 3
  1. #1
    Primary Language: Sarcasm Pony Racer's Avatar
    Join Date
    Jun 2011
    Location
    RiverShit, Ct
    Posts
    480
    +1
    28

    DESS 2010+ ski's possilbe fix?

    everyone that has these skis knows what a P.I.A. it can be to get the DESS to function correctly sometimes..
    hit the start button, put the DESS on, then start the ski..
    even with having the latest software.. sometimes the DESS just beeps once.. and your fiddling with the DESS trying to get it to beep twice

    over the winter i disconnected the battery from the ski and just left it on the trickle charger..
    put the battery back in and out of old habit (from riding friends skis).. popped the DESS on and hit start and held the button..
    ski started right up, and then bepped twice almost imediatly after starting..

    shut the ski off pulled the DESS let it sit while fiddling around with other things..
    popped the DESS back on the post.. pushed and held the start button.. again ski fired right over..

    went out for my first ride of the season over the weekend.. and every time i did the exact same thing..

    ski fired right up like the older skis..

    so it got me thinking.. that maybe disconnecting the battery was never done after the flash update..
    which like all computers resets everything..

    so far it has worked for me something i wanted to pass along for others to try.. to see their results..
    also may help out with the hand held programers if your having issues..

    so if you disconenct your battery leave it disco'ed for at least an hour..


  2. #2

    Join Date
    Oct 2010
    Location
    Pittsburgh, PA
    Posts
    33
    +1
    1
    My 2010 Rxpx has been like that since the day I first picked it up at the dealer just put the dess on hit the start button and go. KInda doubt it has something to do with unhooking the battery.

  3. #3
    Primary Language: Sarcasm Pony Racer's Avatar
    Join Date
    Jun 2011
    Location
    RiverShit, Ct
    Posts
    480
    +1
    28
    Quote Originally Posted by 7.3 Powerstroker View Post
    My 2010 Rxpx has been like that since the day I first picked it up at the dealer just put the dess on hit the start button and go. KInda doubt it has something to do with unhooking the battery.
    never worked like that last year.. i tried several times..the only difference in my ski between this year and last year is the battery was discoed..
    which will wipe the ecm charged memory..

    even the dealer said.. " we just updated the ECM with the latest firmware, ( the day i purchased it), so you shouldnt have any of the "dess issues", just power up, put the DESS on, wait for 2 beeps, then start"..
    on many occasions doing that Exact order the key would beep once .. then have to redo the everything all over again.. and at times took me about 30 sec of trying over and over to get the second beep.


    this also happend 1 time on sat also.. i thoguht i would try the way i was doing it all last year..
    i powered up, put the dess on single beep.. pulled the dess off.. i waited for the display to shut off..
    about 10 sec later i put the DESS on the post.. hit the start and held it.. started right up no issues..

    my point is that the "way" we were told to start these ski, and the way i just tried over the weekend seems to be alot more consistant.. and the only change in my ski was the battery being discoed..thus resetting the memory.. just like you should reboot your computer when installing a new program... is it absolutly nesassary to do so no, but sometimes the program doesnt fully "load in" until the computer is rebooted..

    i could not start my ski like this last year UNLESS, i shut the engine by the start/stop and sat on the ski with the DESS plugged in and even then it would have a 3 min time limit.. anything beyond that i would have to power up the ski with the dess off and then go through the proceedure..

    now i just plug it in and go.. huge difference..

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. DashPac is now available for the older 2003 - 2010 Skis
    By Green Hulk in forum 4-Tec Performance
    Replies: 2
    Last Post: 08-07-2016, 10:04 AM
  2. WTB - Parts Waterbox 2010+ skis and up
    By krouchchocolate in forum Sea Doo Classifieds
    Replies: 4
    Last Post: 11-12-2015, 08:44 PM
  3. 2010 rxt ibr/pump fixing plates
    By BEECHFRONT in forum 4-Tec Performance
    Replies: 6
    Last Post: 06-26-2014, 02:54 AM
  4. 1993 SD GTX. Possible DESS Issue? Ski stutters at excel??? Help
    By Fenderjack in forum 2-Stroke Performance
    Replies: 0
    Last Post: 07-15-2013, 02:40 PM
  5. What makes the 2010 skis turn better?
    By 556SBR in forum 4-Tec Performance
    Replies: 40
    Last Post: 09-17-2009, 09:43 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •