Results 1 to 9 of 9
  1. #1

    die out when it hits the water

    I have a 1993 GTS that I put a new impeller wear ring, cdi box and replaced the crankshaft with a rebuilt unit on a few years ago for a friend. When I got it all back together the ski started up and ran fine on the trailer with the hose hooked up to it. I didn't have a chance to test it in the water before he took it with him back to his lake house up in northern wisconsin. The problem is as soon as the thing hits the water the engine dies out immediately. It starts on the boat lift fine and even if you rev the engine up as you lower it into the water it dies out as soon as it starts sucking water. This was my first time working on a rotax but i've built polaris and other 2 stroke engine before without problems but they were all snowmobiles. I bought the little degree wheel to time the valve and everything and I'm pretty sure thats on correctly. So my buddy finally brought it back down here for me to look at again. Any good ideas of where to start? My first thought is maybe ignition timing or something along those lines. Any help is greatly appreciated.


  2. #2
    AndinoWatercraft's Avatar
    Join Date
    Feb 2008
    Location
    Puerto Rico
    Posts
    306
    +1
    4
    I belive that is a 720 engine. Very reliable one thoug. Since it has been stored for some time do you check the carb and fuel lines for any obstruction?? Are u using fresh fuel? (mix) Check your exhaust hoses . I ran in to a case long time ago that the exhaust hose that goes to the waterbox was like puffed inside obstructing and when the craft was under load it dies .

  3. #3
    Quote Originally Posted by AndinoWatercraft View Post
    I belive that is a 720 engine. Very reliable one thoug. Since it has been stored for some time do you check the carb and fuel lines for any obstruction?? Are u using fresh fuel? (mix) Check your exhaust hoses . I ran in to a case long time ago that the exhaust hose that goes to the waterbox was like puffed inside obstructing and when the craft was under load it dies .

    I think its a 550cc. Anyway it started doing this right after I put it back together, it had not been sitting at that time. The fuel was fresh.

  4. #4
    PWC Addict lilman573's Avatar
    Join Date
    Feb 2010
    Location
    Central NJ
    Posts
    2,947
    +1
    207
    Sounds to me like the fuel filters in the carbs are blocked. I have had a ski run fine on the hose and under load(in the water) it would die. Internal fuel filters ended up being clogged.

  5. #5
    TEAM BRONX TECH FAT BOY's Avatar
    Join Date
    Mar 2009
    Location
    Bronx, NY
    Posts
    353
    Could be a leaky head gasket. I had the same issue with a 750 kawi standup. ran great on the hose but couldn't get it to run as soon as it hit the water. Sure you torqued the head properly?

  6. #6
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    first you need to check the idle. if its too low it will die in the water. now, the last time that I had this happen I had lost a piston. I leaned way out but it would still run out of the water but when i put it in it died. pull the head and inspect for damage.

  7. #7
    Joe Stang's Avatar
    Join Date
    Aug 2008
    Location
    Durham, CT
    Posts
    1,928
    +1
    61
    Had this issue on a boat I just serviced. Internal carb filters were blocked.

  8. #8
    crzyjetskr's Avatar
    Join Date
    Aug 2010
    Location
    The lake
    Posts
    110
    Clean carb high speed jets prob clogged

  9. #9
    check your compression i had the same problem so i checked the compression and it was 60 psi. Thats just my two cents

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 10
    Last Post: 03-09-2015, 09:20 AM
  2. sl750 dies out when hitting the throttle at idle
    By polarisman in forum Polaris Open Discussion
    Replies: 0
    Last Post: 07-11-2011, 11:43 AM
  3. Dies sometimes when i hit a wake going fast
    By johnt365 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 08-20-2007, 10:30 PM
  4. Replies: 4
    Last Post: 05-03-2007, 01:49 AM
  5. Bayou Princess hits the water on her new ski
    By Green Hulk in forum Sea Doo Open Discussion
    Replies: 26
    Last Post: 03-06-2006, 09:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •