Results 1 to 5 of 5
  1. #1

    RXT-X 255 bogging down

    I took my RXT-X out today for the first trip of the year. When I first started out the machine would sputter a bit while idling. I also could only run about 45mph and 6000k rpm. However, once I ran the ski for about 10 minutes it ran fine. About 8000k RPM and 70 on the dream-o-meter. When I took it back to the dock and idled in it once again it gave me some sputtering. Anyone have any insight onto what the problem could be? The ski only has 30 hours on it. I'm thinking possibly bad gas quality from sitting all winter? Maybe the wear ring? Any suggestions would be appreciated. Thanks.


  2. #2

    Join Date
    Jun 2011
    Location
    Southern CA.
    Posts
    29
    +1
    1
    Very likely bad gas. Also could be fouled spark plugs. A dealer once told me after I had a tank of old gas to fill it with premium one time on the next fill up. Always use a gas treatment in the last tank before you store it for the winter.

    Gentletiger

  3. #3
    Never thought about the spark plugs. That is also a real possibility. I put sta-bil in the gas before I winterized the ski so it may not be the gas. Thanks for the reply.

  4. #4
    oct6454's Avatar
    Join Date
    Sep 2008
    Location
    Gig Habor, Washington
    Posts
    758
    +1
    8
    Spark plugs for sure. Especially if you fogged the motor. Go get some new plugs and gas and you'll be good to go!

  5. #5
    SCHNORR12's Avatar
    Join Date
    Mar 2012
    Location
    Lake George, NY
    Posts
    834
    +1
    92
    Quote Originally Posted by theglars View Post
    Never thought about the spark plugs. That is also a real possibility. I put sta-bil in the gas before I winterized the ski so it may not be the gas. Thanks for the reply.
    Spark plugs were the problem with my 2008 STX15F. I was stuck at 30MPH and 4,000 RPMs until I replaced them.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2011 Seadoo RXT bogging down
    By Jeets8584 in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-16-2013, 04:09 PM
  2. 2005 RXT bogging down on turns
    By ndarimont in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-24-2011, 09:28 PM
  3. Rxt-x Rpm Lose And Bogs Down
    By gba in forum 4-Tec Performance
    Replies: 6
    Last Post: 06-26-2008, 12:03 AM
  4. trouble bogging down
    By jonjonwells in forum Polaris Open Discussion
    Replies: 8
    Last Post: 04-22-2007, 10:56 AM
  5. Motor bogs down when jumping...
    By Denali44 in forum 4-Tec Performance
    Replies: 8
    Last Post: 08-08-2005, 03:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •