Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 28

Thread: Ecu year?

  1. #1

    Join Date
    Feb 2012
    Location
    Uk.northwest
    Posts
    43

    Ecu year?

    Was wondering if any one could shed some light on this problem I got guys at local dealer to plug my ski in because was not running right and as he checked his laptop I noticed it said 2007 now I said to guy aye why is it saying 2007 when it was a 2008 ?he said some times they just get put in if there is any left overr from the last stock as it was basically the same ski,now I have read on here a few times that the 2007 is leaner than the 2008 ecu so how come I have a 2007 ecu in a 2008 ski? And considering my ski all of a sudden has started to run like shit with black smoke my mind is going mad thinking wtf is going on its like its not even my ecu any one noticed this Year differance before? Or is it this guys program out date ?


  2. #2
    What model is your ski?
    What's the P/N stamped on your ECU?
    Any code flashing on your dash meter?
    You need to more info so others can help you better.

  3. #3
    Banned User
    Join Date
    Jan 2009
    Location
    LA/oc
    Posts
    3,911
    +1
    129
    07 is actually richer not leaner. Ecu. Look on the vin plate and see what year it says on your ski. Also post the pn of the ecu

  4. #4

    Join Date
    Feb 2012
    Location
    Uk.northwest
    Posts
    43
    Sorry it's a 2008 250x green white I will get the numbers from ski tomorrow

  5. #5

    Join Date
    Feb 2012
    Location
    Uk.northwest
    Posts
    43
    Quote Originally Posted by FIRE0021 View Post
    07 is actually richer not leaner. Ecu. Look on the vin plate and see what year it says on your ski. Also post the pn of the ecu
    I ment richer sorry I just knew I read some were it was one or the other but could not remember to hand and was just trying to give some kind of idea as to what I was thinking ,will post details ASAP
    Thanks for replys.

  6. #6

    Join Date
    Feb 2012
    Location
    Uk.northwest
    Posts
    43
    Also no codes what so ever even on laptop guy changed ssome black plastic thing just below the silver dump valve I think it's to do with throttle no change either just started if I revved throttle but then died soon I as let throttle go,also would not start with out me blipping throttle ,but it used to just start with out touching throttle,guy seems puzzled at shop and is going to test individual parts over next few days after the holidays As it isn't showing no codes on dash or laptop so the easy way is out the window

  7. #7
    Quote Originally Posted by Steme123 View Post
    Sorry it's a 2008 250x green white I will get the numbers from ski tomorrow
    Green/white means 2008 model, at least the hull is.

    How to identify the ECU year:
    If the last 2-digit is 33, it's 2007.
    If the last 2-digit is 38, it's 2008.

    Also, check the engine serial number (13-alphanumeric code) which can be found in 2 plasces.
    1. A paper label on top/valve cover (if still there).
    2. A stamping mark on top of the generator cover in the rear of the engine, little difficult to get to but it's there. It should start something like JTT50BE...

    Your ski problem sounds like the Idle Speed Control Valve (stepper) motor/assembly went bad.
    P/N 161723705 is for the complete assy consiting of the motor, housing and sensor inside.
    P/N 211740555 is for the motor itself only.
    If you put your hand over the ISC housing and feels too warm when engine is running, the ISC motor is defitnitely shot.

    Before replacing above, you should do basic checks like:
    > Compression
    > Plugs
    > Good fuel, etc.

  8. #8

    Join Date
    Feb 2012
    Location
    Uk.northwest
    Posts
    43
    Quote Originally Posted by meangreenman View Post
    Green/white means 2008 model, at least the hull is.

    How to identify the ECU year:
    If the last 2-digit is 33, it's 2007.
    If the last 2-digit is 38, it's 2008.

    Also, check the engine serial number (13-alphanumeric code) which can be found in 2 plasces.
    1. A paper label on top/valve cover (if still there).
    2. A stamping mark on top of the generator cover in the rear of the engine, little difficult to get to but it's there. It should start something like JTT50BE...

    Your ski problem sounds like the Idle Speed Control Valve (stepper) motor/assembly went bad.
    P/N 161723705 is for the complete assy consiting of the motor, housing and sensor inside.
    P/N 211740555 is for the motor itself only.
    If you put your hand over the ISC housing and feels too warm when engine is running, the ISC motor is defitnitely shot.

    Before replacing above, you should do basic checks like:
    > Compression
    > Plugs
    > Good fuel, etc.


    I got guy at shop to change that isc little plastic valve ,ski still same started if I reved it but soon as I let go rev it conked out,I have to wait till holidays are over till he will look at ski shops full jobs,allways my luck .i even just rang mate who I sent for petrol asking where he got the juice from he said bp so I carnt see it being that unless I have ended up putting diesel in an I doubt that very much,I hope ...plugs were fine I even put new set in just incase.

  9. #9
    Then it sounds like a mechanical problem.
    Check compression and cam timing.

  10. #10

    Join Date
    Feb 2012
    Location
    Uk.northwest
    Posts
    43
    Quote Originally Posted by meangreenman View Post
    Then it sounds like a mechanical problem.
    Check compression and cam timing.
    The guy at lake suggested that on day it happend he said it seemed like it had jumped on the timming chain is that commen?

    Also he checked compression and all was fine except number 3 was maybe 3 or 4 psi down from the others and as he hasn't really dealt with kwaks he couldn't put his finger on it so to speak! So am just waiting to see what guys at other shop come up with it only has 38 or some were nere I think hours on it,
    what do I do now?
    Order new pistons and a head?
    pick a tree?
    Or is this a simple fix?

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB Riva ecu year +2007
    By SingTH in forum Sea Doo Classifieds
    Replies: 4
    Last Post: 12-02-2013, 02:33 AM
  2. Ecu options for 185 specific to 2006 model year
    By Pete1027 in forum 4-Tec Performance
    Replies: 5
    Last Post: 03-29-2013, 08:58 AM
  3. fx ho ecu differences between years?
    By slociviccoupe in forum Yamaha PWC Performance (4-stroke)
    Replies: 1
    Last Post: 09-25-2011, 10:04 PM
  4. Wich year MPEM and ECU for 2005 rxt??
    By xpl2008 in forum 4-Tec Performance
    Replies: 0
    Last Post: 10-03-2009, 12:32 PM
  5. WTB: 4tec Racing ECU's - Any year or type, doesnt matter!
    By boostaholic in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 03-28-2009, 04:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •