Results 1 to 5 of 5
  1. #1

    Join Date
    Apr 2010
    Location
    Michigan
    Posts
    194

    Rear Bolts on Ride plate just spin when trying to remove them, please help.

    I am trying to replace the wear ring on a 98 GP760. When removing the ride plate the front bolts came out but the rear ones stated to come out then just spin. So the sleeves in the hull are turning. I cannot see any sleeve from inside the ski. What can I do? Thanks.


  2. #2
    crashhard's Avatar
    Join Date
    Jul 2007
    Location
    Philly PA, Wildwood NJ, Indialantic FL
    Posts
    2,382
    +1
    24
    Pull everything out, so you can see them ( waterbox, styrofoam) get a pair of vise grips and get on the on spinning ones. Then 5200 themback in place after removed. Make sure your the old glue is gone and let them sit before reinstalled the plate .

  3. #3

    Join Date
    Apr 2010
    Location
    Michigan
    Posts
    194
    Quote Originally Posted by crashhard View Post
    Pull everything out, so you can see them ( waterbox, styrofoam) get a pair of vise grips and get on the on spinning ones. Then 5200 themback in place after removed. Make sure your the old glue is gone and let them sit before reinstalled the plate .
    hey Joe,
    Thanks for the info. I looked at the area again and found the sleeve sticking up. Locking pliers applied and I am in business. Thanks.

  4. #4
    Just relax and enjoy the ride. XLT Chad's Avatar
    Join Date
    Jan 2011
    Posts
    1,284
    +1
    116
    Quote Originally Posted by crashhard View Post
    Pull everything out, so you can see them ( waterbox, styrofoam) get a pair of vise grips and get on the on spinning ones. Then 5200 themback in place after removed. Make sure your the old glue is gone and let them sit before reinstalled the plate .
    I agree except for" 5200 them back in place" IMO, thats not going to properly secure them. once they spin, they are junk. I would clean the area up and install an aftermarket bracket or make your own out of some aluminium bar stock. Use the ride plate as a template. then use 5200 to seal everthing in place.

  5. #5
    crashhard's Avatar
    Join Date
    Jul 2007
    Location
    Philly PA, Wildwood NJ, Indialantic FL
    Posts
    2,382
    +1
    24
    Yea it's only a gp, not gpr. Yea you could make some but i always just cleaned the area real good and re-installed with a good epoxy or 5200. It's been years since I have had to do it on a gp and that god because it's a pain. Glad you got it out.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 2
    Last Post: 05-09-2014, 12:18 PM
  2. Bolt head broke off on ride plate.
    By kopfb in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 08-04-2011, 09:47 PM
  3. Replies: 1
    Last Post: 07-27-2011, 10:31 AM
  4. Stage I/Bolt Ons/Ride Plate Holes
    By JFizzleJR in forum 4-Tec Performance
    Replies: 1
    Last Post: 05-14-2006, 11:15 PM
  5. Bolt On Ride Plate Extension
    By johnD in forum 4-Tec Performance
    Replies: 18
    Last Post: 05-01-2006, 05:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •