Page 1 of 5 1 2 3 ... LastLast
Results 1 to 10 of 46
  1. #1

    Join Date
    Jul 2011
    Location
    canada
    Posts
    297

    after i put the riva pump wedge and the spead freak impeller nose cone i lost 3 mph

    do you know how can i lost 3 mph after i put those 2 parts

    wather was 50'f no wave like a miror
    my best top speed was 74 and last week was 77 with no nose cone and pump wedge


  2. #2
    eric1238's Avatar
    Join Date
    Jun 2005
    Location
    Smith Mtn. Lake VA
    Posts
    728
    +1
    2
    Where are you located? Was there a drastic weather change? What was the RPM difference between the two days?

  3. #3

    Join Date
    Jul 2011
    Location
    canada
    Posts
    297
    im from quebec canada its cold here

    perfect day to test the machine and the number are not really good for me

    8600rpm

  4. #4
    skigolfnut's Avatar
    Join Date
    Jun 2009
    Location
    League City TX
    Posts
    1,979
    +1
    33
    not all mods do the same for each ski, and a lot of people post false speeds,

  5. #5
    icdoo's Avatar
    Join Date
    Feb 2011
    Location
    Iowa
    Posts
    381
    +1
    23
    Quote Originally Posted by skigolfnut View Post
    not all mods do the same for each ski, and a lot of people post false speeds,
    +1

  6. #6
    surferd15's Avatar
    Join Date
    Jun 2007
    Location
    Fort Lauderdale, FL
    Posts
    1,142
    +1
    83
    Maybe your pump isnt sealed tightly, or your carbon ring.

  7. #7
    JT jpt7779's Avatar
    Join Date
    Jul 2008
    Location
    Pittsburg, Texas Lake Bob Sandlin
    Posts
    3,851
    +1
    742
    No one is going to be able to accurately help you if you don't post year, model, mods of your ski!

  8. #8
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Quote Originally Posted by jpt7779 View Post
    No one is going to be able to accurately help you if you don't post year, model, mods of your ski!
    +1

  9. #9
    ou812's Avatar
    Join Date
    Jun 2006
    Location
    Riverside,ca
    Posts
    6,210
    +1
    198
    You sure you didn't put the wedge on upside down? That will push the nose down and cost a few mph easily.

    If you were getting the same RPM before & after I'd say it's upside down

  10. #10

    Join Date
    Jul 2011
    Location
    canada
    Posts
    297
    Quote Originally Posted by ou812 View Post
    You sure you didn't put the wedge on upside down? That will push the nose down and cost a few mph easily.

    If you were getting the same RPM before & after I'd say it's upside down
    the wedge is in the correct position

Page 1 of 5 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Riva Pump Extension and Wedge
    By pdxrealtor in forum 4-Tec Performance
    Replies: 49
    Last Post: 10-14-2010, 10:52 PM
  2. WTB RXP Riva pump wedge and trim cable extension
    By fcs1965 in forum Sea Doo Classifieds
    Replies: 3
    Last Post: 06-16-2009, 08:56 PM
  3. Pump wedge and its effect on warranty
    By ercBOOSTED in forum Kawasaki PWC Performance (4-stroke)
    Replies: 7
    Last Post: 05-17-2007, 10:49 PM
  4. concerned about Riva pump wedge
    By catchme in forum 4-Tec Performance
    Replies: 22
    Last Post: 02-03-2007, 09:56 AM
  5. Bought RIVA Pump wedge...Missing spacer!! And need directions
    By majundecid in forum 4-Tec Performance
    Replies: 6
    Last Post: 07-08-2006, 06:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •