Results 1 to 3 of 3
  1. #1

    Join Date
    Nov 2009
    Location
    NC
    Posts
    783
    +1
    29

    Found a valve on hose inlet

    Rebuilt a 2001 XLT that dropped a PV pin. Fired up ok so decide to put it on hose before dropping in water. Someone had replaced factory hull fitting with plastic female hose fitting. Convenient. Attached hose, started ski, turned on water and waited. 25 seconds later no water coming out of ski anywhere so shut off water, undid fitting, spraying water everywhere, and cut off ski. Thought line was plugged somewhere. Found a "coupler" about 5" down from female hose fitting. Disconnected it. Turns out it's not just a coupler there was a filter, too. Hook the hose back up, turn it on, no water comes out. Maybe some sort of one-way filter? Swap ends thinking someone installed backwards, still no water through. Put air to it, still nothing. Accidentally squeezed it then got air through. Air would flow either way once spring inside it was compressed. No way water pressure could make it function.
    Don't see any kind of one-way, or check valve in parts manual for the hose intake. Can't figure out why anyone would put a valve there to begin with, let alone one that could not possibly function.


  2. #2

    Join Date
    Nov 2009
    Location
    NC
    Posts
    783
    +1
    29
    After examining other skis, a spring loaded valve is activated by pushing Yamaha male fitting down into female fitting attached to ski. I gather the valve prevents water from spitting out through hose connection fitting rather than cooling engine. Still can't figure out why someone would install the same type valve 5" below top of hull. Ski could never be run off the hose that way as nothing can open valve.

  3. #3

    Join Date
    Nov 2009
    Location
    NC
    Posts
    783
    +1
    29
    So there is valve to prevent water from coming out hose attachment when ski is on lake/river/ocean, thus making sure it all cools motor. Why is there no valve to force all water through motor when on hose? Am I just missing it?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Which hose to install water intake water cutoff valve on
    By Stever in forum Yamaha How To & FAQs
    Replies: 1
    Last Post: 11-05-2014, 01:40 PM
  2. universal BOV valves on ebay
    By TOQUICK250X in forum Kawasaki PWC Performance (4-stroke)
    Replies: 2
    Last Post: 07-30-2007, 05:02 AM
  3. check valves on bailers ok??
    By BoostedH23a1 in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-19-2007, 06:29 AM
  4. flush hose inlet block testing
    By DIGGS in forum 4-Tec Performance
    Replies: 2
    Last Post: 06-25-2007, 09:34 AM
  5. Question on air inlet hoses------>>>>>
    By earthshaker in forum Kawasaki PWC Performance (4-stroke)
    Replies: 11
    Last Post: 06-19-2007, 10:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •