Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1
    rxpzz's Avatar
    Join Date
    Oct 2008
    Location
    Sydney, Australia
    Posts
    128

    Slip on x charger?

    Ppls, would my washers be gone if I've got 5 mc masters and two
    shims in and can't even get it to hold? X charger 60hrs?
    thanks in advance


  2. #2
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    Something is wrong. A good X SCer only needs 2-3 McMaster washers to get the slip right with gold washers. It should be locked up with what you have done.

  3. #3
    Sayers's Avatar
    Join Date
    Jul 2010
    Location
    Melbourne AUS
    Posts
    2,300
    +1
    134
    Have you checked tolerances? The gear may have excessive wear.

    How do you have the spring washers setup?

  4. #4
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Quote Originally Posted by jp1300r View Post
    Something is wrong. A good X SCer only needs 2-3 McMaster washers to get the slip right with gold washers. It should be locked up with what you have done.
    +1...

  5. #5
    rxpzz's Avatar
    Join Date
    Oct 2008
    Location
    Sydney, Australia
    Posts
    128
    same way the oem's came out?
    could it be that worn??

  6. #6
    Sayers's Avatar
    Join Date
    Jul 2010
    Location
    Melbourne AUS
    Posts
    2,300
    +1
    134
    Quote Originally Posted by rxpzz View Post
    same way the oem's came out?
    could it be that worn??
    Shouldn't be with just 60hrs, seems like something is out of whack.

    Have you measured the gear? The service limit is 10.7mm, new should be 11mm, 11.050 max.

    How do you have the washers set? )()()?

  7. #7
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Quote Originally Posted by Sayers View Post
    Shouldn't be with just 60hrs, seems like something is out of whack.

    Have you measured the gear? The service limit is 10.7mm, new should be 11mm, 11.050 max.

    How do you have the washers set? )()()?
    +1...

    RXPZZ,
    Did you buy this Scer new or used???60 hours shouldnt be that bad....Did you check to see what the gear face looked like also???I would pull it all back apart and measure the gear,Thrust washer,L collar and clutch washers and then visually inspect everything...Also the reason i asked if its new or used is if its used somebody could have sanded down the L collar and if they did you might be chasing yourself trying to get it set right......Also When inspecting look at the shaft to see if the thrust collar hasnt twisted and covered up the oil hole...I have seen this happen and once it cuts the oil off it wears the shit out of the gear and clutches....

  8. #8
    rxpzz's Avatar
    Join Date
    Oct 2008
    Location
    Sydney, Australia
    Posts
    128
    sayers, ive put them in like that?
    snoman, im going to strip it and check all measurements.
    Was a second hand ski so.

  9. #9
    idoodou's Avatar
    Join Date
    Mar 2009
    Location
    cincy,ohio
    Posts
    765
    +1
    30
    i'm only getting 93 in/lbs i know it should be higher remind me where the shim goes

  10. #10
    idoodou's Avatar
    Join Date
    Mar 2009
    Location
    cincy,ohio
    Posts
    765
    +1
    30
    was able to get it adjusted to 127 in/lbs with two shims tried three but was at 200 which i think is to much

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. How do I check slip on x charger out of ski?
    By toxicgun in forum 4-Tec Performance
    Replies: 10
    Last Post: 08-20-2016, 10:25 AM
  2. problems with slip on a x charger
    By 800AMSOIL4U in forum 4-Tec Performance
    Replies: 8
    Last Post: 07-05-2015, 10:02 AM
  3. Getting 14lbs of slip on 2Rude charger
    By Gus13letter in forum 4-Tec Performance
    Replies: 16
    Last Post: 03-22-2009, 09:30 AM
  4. How bad is 7 and 8 pounds of slip on two different rudes?
    By Alex13 in forum 4-Tec Performance
    Replies: 3
    Last Post: 09-13-2008, 11:00 PM
  5. Update on X charger in RXP
    By dpoole5074 in forum 4-Tec Performance
    Replies: 7
    Last Post: 08-24-2008, 10:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •