Results 1 to 9 of 9
  1. #1

    Join Date
    May 2012
    Location
    australia
    Posts
    2

    Cool gp1300 cavatation issue

    Hi guys im having an issue with hole shot and getting to much cavatation and starting to give me the shits , and to be honest i think my top end speed is all that as well , i have just installed the riva pump seal kit and still nothin so i need some help , the ski is a 03 gp1300 stock with no intake or rideplate yet , an the ski has been in fresh water before i got to it so some help would be of some great help


  2. #2
    Banned User
    Join Date
    Aug 2011
    Posts
    5,049
    +1
    238
    a grate will help you

  3. #3
    cmgww's Avatar
    Join Date
    Jun 2010
    Location
    Indianapolis, IN
    Posts
    314
    +1
    8
    An intake grate will make all the difference. It is a design flaw..the stock grate is terrible and I often winder why Yamaha didnt adress it after the first year, as this was their top dog ski for a long time

  4. #4
    crashhard's Avatar
    Join Date
    Jul 2007
    Location
    Philly PA, Wildwood NJ, Indialantic FL
    Posts
    2,382
    +1
    24
    its an 03 probably still on the original wear ring. Thats the first place to start for cavitation, when you mention the top speed check the prop for bends or dings, that will slow you down.

  5. #5
    porschemaniac's Avatar
    Join Date
    Apr 2009
    Location
    missouri
    Posts
    1,271
    +1
    32
    First thing would be pull pump and check wear ring and impeller conditions. Definitely put in a ppk and then grate. Need wear ring- impeller and ppk operating properly first then if you still want better hookup get a double bar grate

  6. #6

    Join Date
    May 2012
    Location
    australia
    Posts
    2

    Wink reply

    Quote Originally Posted by porschemaniac View Post
    First thing would be pull pump and check wear ring and impeller conditions. Definitely put in a ppk and then grate. Need wear ring- impeller and ppk operating properly first then if you still want better hookup get a double bar grate
    thanks for the replys guys next stop ski shop for some parts ill keep you informed
    thanks again

  7. #7
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23
    Welcome to the forum

  8. #8
    bgruhn76's Avatar
    Join Date
    Apr 2012
    Location
    Clearwater, Florida, United States
    Posts
    217
    +1
    3
    Hey man, I just had same issues you did on my 04. Did Riva grate and pump seal kit, new wear ring, new stock impeller, HOLY difference! Now....to find my bogging issue. LOL

    Good luck!

  9. #9
    cmgww's Avatar
    Join Date
    Jun 2010
    Location
    Indianapolis, IN
    Posts
    314
    +1
    8
    Does anyone know why Yamaha never addressed this on the GPRs? I know for sure they didn't through at least 04...but demo riders had to have complained enough (along with buyers) that a simple revision of the grate could have been done...the stock setup could have been SO much better at not much cost to Yamaha. But I guess we live and learn, seeing as most of the new 4 strokers (at least the high performance ones) come standard with "aftermarket" style grates. Sure they all can be improved upon, but to have these fundamental flaws for so long on Yami's then top performing ski just seems weird and out of place for a company that holds the crown, IMO, for fit and finish and reliability

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. More on my cavatation issues - Part 2 - PIC
    By Drok512 in forum 4-Tec Performance
    Replies: 18
    Last Post: 09-07-2013, 11:42 AM
  2. Possible Cavation Issue?
    By jnizzle01 in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 08-03-2011, 07:09 AM
  3. gp1300 throttle response issue
    By hooksgp1300 in forum Yamaha How To & FAQs
    Replies: 0
    Last Post: 07-17-2010, 08:55 PM
  4. Gp1300 oil issue
    By Private in forum Yamaha How To & FAQs
    Replies: 5
    Last Post: 05-27-2010, 11:14 AM
  5. Stage I Issues on GP1300
    By jaycee in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 08-12-2007, 10:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •