Page 1 of 5 1 2 3 ... LastLast
Results 1 to 10 of 45
  1. #1

    Just bought a ultra 250x with some issues.. Fools and money...

    Hey i just bought a ultra 250x with super low hours on it and was told the only thing wrong with it was that the belt needed replaced.

    after 2 hours i finally have the superchargers belt replaced. I used the correct tension tool which shows the marker right in the middle.

    Now...

    I start the ski up and it starts easily like it did before but it has a few more problems...

    There is a loud squeal coming from the engine bay.. sounds like the belt is loose??? yes so i tightened it above spec and it changed nothing.. not in the slightest..

    another thing that happens.. when i rev the bike there is no high revs.. in the video im giving it full throttle and it doesn't rev up.. it just sits low and then when throttle is taken off it dies.

    Does anyone know whats wrong with this POS??? any help would be appreciated, failing that.. ULTRA 250x FOR SALE, MINT CONDITION. ONLY NEEDS A $35 BELT..



  2. #2
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    did you spin the pulleys on the s/c and idler when the belt was off? did you correctly re-align the engine? is the tensioner correctly installed (i jhave seen one missing the rear collar) is the prop spinning freely?

  3. #3
    tensioner pulley is together properly with the spacer part to the rear.. the s/c pulley seemed to spin freely. i slid the engine back after installing the belt with a piece of wood and it looks straight i guess. i didn't actually do an alignment and I'm not sure how to.. i don't think that would explain the lack of revs when the throttle is opened up fully tho and the fact it dies straight after i let go of the throttle. didn't check the prop to be honest... could it be the supercharger thats bad?

  4. #4
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    thats why i asked did you spin the s/c when the belt was off? are all hose clamps from the s/c to the i/c and throttle body tight? could be a simple boost leak. if not guessing the s/c is rooted

  5. #5
    Banned User
    Join Date
    Jan 2009
    Location
    LA/oc
    Posts
    3,911
    +1
    129
    Your sc is toast.

  6. #6
    How do u know?

  7. #7
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    because you asked what we thought was wrong!!!!!!!!!!!!! we are not experts just trying to help you, all the symptoms you have explained point to a failed s/c.........

    Quote Originally Posted by skibru View Post
    How do u know?

  8. #8
    Banned User
    Join Date
    Jan 2009
    Location
    LA/oc
    Posts
    3,911
    +1
    129
    And because if that's your motor making that noise your fucked lol. Symptoms as nic said add up to that.

  9. #9

    Join Date
    Jul 2011
    Location
    ct
    Posts
    62
    you gotta figure there's something more to it when stuff is for sale like that. if you were selling a ski and it just needed a belt wouldn't you just replace it and get full price.

  10. #10
    Does a broken supercharger stop the rpm rising and cause the engine to stall when the throttle is released?

Page 1 of 5 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Bought 08 ultra 250x, RPM's ok but low top speed issue
    By cratica in forum Kawasaki PWC Performance (4-stroke)
    Replies: 8
    Last Post: 05-13-2012, 02:28 PM
  2. 2007 Kawasaki Ultra 250X With 2010 Single Trailer 7,500 TX
    By neversatisfiedmotorsports in forum Kawasaki Skis
    Replies: 2
    Last Post: 07-02-2009, 06:07 PM
  3. Ultra 250x With R&d Stage 1,with Pulley 1.1
    By ULTRA 250XXX in forum Kawasaki PWC Performance (4-stroke)
    Replies: 21
    Last Post: 06-24-2008, 11:54 AM
  4. ULTRA 250X vs ULTRA 250X WITH RIVA RIDE PLATE
    By ULTRA 250XXX in forum Kawasaki PWC Performance (4-stroke)
    Replies: 9
    Last Post: 09-10-2007, 04:31 PM
  5. Just bought an 06 RXP, need some advice!
    By NeverEndn in forum 4-Tec Performance
    Replies: 13
    Last Post: 07-11-2006, 12:20 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •