Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1

    Ready to sink my MSX 150

    I have a over heating problem. I runs about 10 min an a overheating light come on. I have unplugged to sensor on left and it still does overheats. I replaced the sensor on intake side between injectors and no good results. I used my heat sensing gun and got 165 near head where the sensor I replaced is. Its only 110 on exhaust side. I don't want to sell it because I really enjoy the 10 miniutes I get everytime. About the same exoerience I have with my wife. Please help.


  2. #2

    Join Date
    Apr 2010
    Location
    Stamford CT
    Posts
    129
    What do you do to get the light to clear? Do you shut the ski off? Have you tried letting it idle to see if the light clears?

  3. #3
    I've heard nothing but bad stuff about the MSX 150, I really hope u get yours figured out and never have a problem with it again.

  4. #4
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Quote Originally Posted by nick072010 View Post
    I've heard nothing but bad stuff about the MSX 150, I really hope u get yours figured out and never have a problem with it again.

    I have heard they are awesome when they are running right!!!

  5. #5
    Matrix 4-Tec spannerspencer's Avatar
    Join Date
    Nov 2010
    Location
    south west England
    Posts
    1,143
    +1
    38
    have you checked you thermostate is ok? check things one at a time.

    remove your thermostat and pop it in near boiling water and prove it opens, and shuts when temp drops.

    does the water seem hot in the bottom of expansion chamber?? (feel externaly) you need to prove water is going around. i would doubt its water pump.

  6. #6
    Thanks for great reply. Yes it does go out after it idles about 3 min..

  7. #7
    Kosh's Avatar
    Join Date
    Sep 2007
    Location
    Australia
    Posts
    1,483
    +1
    83
    You may have a restriction in your raw water system, the last owner may have injested sand or some mud etc that is in the system hindering good flow, For somewhere to start I would be flushing the hoses and heat exchanger out, start flushing individual hoses and prove there is no restrictions. check things such as a crack in the main pump supply tube at the pump, damaged blocked intake screen.

    Difficult to sink, there is a lot of foam in there, from experience full of water it will still support your weight. Let us know how you go getting it to the botom if you decide to go that route, oh and video it please.

  8. #8
    Matrix 4-Tec spannerspencer's Avatar
    Join Date
    Nov 2010
    Location
    south west England
    Posts
    1,143
    +1
    38
    good idea, like kosh said, back flush the water-to-water heat exchanger, and the intercooler water matrix. wont hurt to prove these are fine.

    (when you flush engine with a garden hose, can you see water coming out of inside the jet pump nozzle to the right)? it should gush out of there (the intake screen) when you back flush the system.

    you will see water exiting from the left side of the hull, but thats just water going threw turbo/exhaust

  9. #9
    Quote Originally Posted by BryanP View Post
    I have heard they are awesome when they are running right!!!
    Yeah these things are beasts just had alot of bugs and then Polaris coped out of the ski business after they made it so nothing got worked out, I know there main flaw has something to do with oil junking up every sensor in sight or something LOl. I also heard a rumor Polaris is getting back in to skis???? Is this true?

  10. #10
    I did a water pump test on my MSX 150. I took cap off of water resevor and started it. I watched the return line. At idle not much comes out. Rev it up a little and the return line delivers. So no water return at idle. Only with a little throttle about 1000-1200 RPMs. Is my water pump working right?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 13
    Last Post: 07-05-2015, 02:41 PM
  2. how to test my fuel pump on my msx 150 ???
    By isaacv375 in forum MSX/Matrix
    Replies: 7
    Last Post: 05-01-2013, 10:39 AM
  3. Decided to sell my MSX 150
    By angelsfann02 in forum Polaris Open Discussion
    Replies: 1
    Last Post: 07-16-2011, 02:40 PM
  4. Ready to junk my polaris
    By snoopy'sbitch in forum Polaris Open Discussion
    Replies: 17
    Last Post: 06-10-2010, 08:45 PM
  5. Guess how much I sold my MSX 150 for?
    By angelsfann02 in forum Polaris Open Discussion
    Replies: 7
    Last Post: 10-13-2009, 03:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •