Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22
  1. #1

    Polaris 1996 slt 780 Dies at full throttle

    Ok, so this happened the first time this today. Running my 96 780slt at top speed, after about 5-10 seconds wide open it would die completely. I could restart immediately (while I was still on plane). At less than full throttle I didn't experience this and everything was fine. Had the carbs cleaned and they replaced the stator.


  2. #2
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Has the engine been rebuilt lately?

  3. #3
    No. Compression is great. Run fantastic exept for it dying at WOT. Sounds like it might be electrical since I can restart it so quickly. Like I said the stator has been replaced, could it be faulty?

  4. #4
    Also, I noticed that at mid throttle it is very jerky. (If that make any sense)

  5. #5
    Polarisitis loonatik's Avatar
    Join Date
    May 2010
    Location
    Tampa, FL
    Posts
    812
    +1
    10
    I'm no expert here but a bit of history on this ski would help figuring out what's wrong. I'm sure lots of GH'er here will ask for the same thing.
    How long have you had this ski?
    Has it been sitting long?
    What have you done to it?
    Did it die instantly at WOT or gradually?
    and everything else you'd think it would help diagnosting it.

  6. #6
    No I haven't had it long. It only has 98 hours . Carbs have been cleaned , new stator, plug wires, plugs, head gasket, great compression.
    It will die instantly(no bogging, just like you pulled the lanyard) after about 5-10 seconds at WOT. Then I can restart it instantly while still on plane and take off and go WOT and it will die and do it again.

  7. #7
    Polarisitis loonatik's Avatar
    Join Date
    May 2010
    Location
    Tampa, FL
    Posts
    812
    +1
    10
    Seen that you have looked at other thread with same problem:
    http://www.greenhulk.net/forums/show...8954&page=2#12

    The OP didn't report back so nobody knows what the culprit was. Let's start with possibility of a lean seizure as suggested in the thread.

  8. #8
    With it doing that it would still be able to refire instantly? What then would the plugs look like? And the fix would be?
    Just to make sure what should the carbs be set at(sea level)

  9. #9
    Polarisitis loonatik's Avatar
    Join Date
    May 2010
    Location
    Tampa, FL
    Posts
    812
    +1
    10
    -Don't know, never had this problem.
    -Just taking plug out to check its color will not show you anything. See Tech Section for proper plug reading procedure. Better yet, piston wash is prefered over plug reading, so while you're there look up 'piston wash'.
    -Fix would be getting proper fuel/air ratio, and perhaps some cylinder honing if damage is already done.
    -There're 2 different engines for ski, check it out see what yours is, see below:
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	1996_sl-stl780.JPG 
Views:	295 
Size:	79.3 KB 
ID:	271409  

  10. #10
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    When I experienced this issue.it was a cold seizure.

    How cold is the water temp your riding on right now? And do you have the thermostat installed?

    Can you get us a pic of the piston domes? (need to remove the heads)

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 99 GTX Limited Dies At full Throttle
    By blacktop in forum 2-Stroke Performance
    Replies: 13
    Last Post: 05-06-2013, 07:21 AM
  2. Polaris 1996 SLT 780 Carb Issues / Manual Needed
    By Water Toy in forum Polaris PWC Performance
    Replies: 13
    Last Post: 05-16-2012, 04:31 PM
  3. 785 died at full throttle
    By killcraft in forum Polaris PWC Performance
    Replies: 5
    Last Post: 06-09-2011, 02:00 PM
  4. Bilge pump for Polaris 1996 SLT 780.
    By pastordug in forum Polaris Classifieds
    Replies: 3
    Last Post: 09-08-2009, 10:38 PM
  5. 1997 Polaris 780 SLT (Cutting out at full throttle)
    By harleyfun1996 in forum Polaris Open Discussion
    Replies: 20
    Last Post: 03-24-2008, 01:02 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •