Results 1 to 8 of 8
  1. #1
    policano's Avatar
    Join Date
    May 2012
    Location
    Woodbury, Minnesota, United States
    Posts
    51

    94 Polaris SLT 750- No Electrical Power

    Hello,

    I am hoping someone has some information on what I can check to find out why I have no power now. This morning it started right up. When I arrived at the cabin and tested it again I have no power at all. I can only find one fuse in the black electrical box 1/4 amp. I replaced it with another 1/4 Amp and still nothing. What else can I check? Is there a power fuse for starting? Thanks


  2. #2
    stubburnjdh's Avatar
    Join Date
    Jun 2009
    Location
    Front Royal VA
    Posts
    365
    check your battery connections and make sure they are clean and tight. Also make sure your battery has power

  3. #3
    policano's Avatar
    Join Date
    May 2012
    Location
    Woodbury, Minnesota, United States
    Posts
    51
    Thanks. I checked that I have the battery tight. I used my multi meter and I have 12.5. I also have a brand new battery. Are there fuses to check somewhere?

  4. #4
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    There's a circuit breaker on the elec box try resetting it.

    And do you have a plastic cover between your battery and elec box?

  5. #5
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    If resetting the circuit breaker doesn't work, try bypassing it to eliminate that as the problem. However do not run the ski without the circuit breaker. If you bypass the circuit breaker and it works, replace the circuit breaker. They are around 15 bucks new from Polaris.

  6. #6
    policano's Avatar
    Join Date
    May 2012
    Location
    Woodbury, Minnesota, United States
    Posts
    51
    Thanks! We actually just got off the lake. It worked! We took off the electrical panel and there was a wire loose.

    Here's something. I have never owned a 3 seated before. I was moving around 35 and tried turning. It didn't do anything. I had the stearing all the way to the left or right and it just goes straight. when I back off and slow down some I can turn again.

    Any ideas?

  7. #7
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Check your steering cable at both ends. Make sure its not bending or broken.

  8. #8
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    The ski must be under throttle to turn. Without throttle there is no thrust. Without thrust, there is no steering.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 3
    Last Post: 08-24-2015, 05:22 PM
  2. polaris SLT 750 no power
    By speaksr in forum Polaris Open Discussion
    Replies: 1
    Last Post: 04-11-2011, 12:37 AM
  3. Polaris slt 750 no fire
    By tmintz5 in forum Polaris How To & FAQs
    Replies: 9
    Last Post: 06-22-2009, 09:26 PM
  4. 94 Polaris SLT 750
    By Yammerhead in forum Polaris Open Discussion
    Replies: 27
    Last Post: 09-19-2008, 02:36 AM
  5. 95 polaris slt 750 no spark
    By The Joker in forum Polaris How To & FAQs
    Replies: 5
    Last Post: 11-20-2006, 06:58 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •