Page 1 of 2 1 2 LastLast
Results 1 to 10 of 19
  1. #1

    Join Date
    May 2012
    Location
    Milwaukee Wisconsin Area
    Posts
    20

    Loss of full power - Polaris SLT 750 (blue engine)

    Was running great and all of a sudden slowed down and will not go faster than 19 miles an hour..could it be the fuel pump...it idles fine but will not increase in speed after half throttle. Has new plugs and its getting oil.


  2. #2
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Check your plugs. Check engine compression. Report back what you find.

  3. #3
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    Yep, compression test for sure....

  4. #4

    Join Date
    May 2012
    Location
    Milwaukee Wisconsin Area
    Posts
    20
    you guys are great..no compression in one cylinder...I assume it the reed valves since the problem was intermittent for a few minutes,,,I slowed down..went to full speed then slowed down....picked back up, then did not go over 20 miles an hour. If it was a hole in piston it would of just died. Any suggestions on a good site to get parts from? I figure I will also rebuild rest of valves, rebuild fuel pump and oil pump while I am at it.

  5. #5
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    You'd better remove your heads and inspect. Failing reeds shoukdn't really affect compression

  6. #6
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Quote Originally Posted by xlint89 View Post
    You'd better remove your heads and inspect. Failing reeds shoukdn't really affect compression
    +1 Something else failed....

  7. #7

    Join Date
    May 2012
    Location
    Milwaukee Wisconsin Area
    Posts
    20
    Can see much looking into the spark plug hole but it looks fine from what I can see. I am going to remove the Reeds tonight but don't understand what the reeds would not cause problem. I the reed sticks open or breaks you would not have any compression right?

  8. #8

    Join Date
    May 2012
    Location
    Milwaukee Wisconsin Area
    Posts
    20
    Will remove heads tonight and report back tomorrow.

  9. #9
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Quote Originally Posted by pnyride View Post
    Can see much looking into the spark plug hole but it looks fine from what I can see. I am going to remove the Reeds tonight but don't understand what the reeds would not cause problem. I the reed sticks open or breaks you would not have any compression right?
    No. The reeds allow air/fuel mix into the lower chamber when the piston is travelling up. When the piston travels down, the lower chamber enters compression, closing the reeds, and forcing the air/fuel mix through the ports into the combustion chamber. If the reeds are not present, the air fuel mix will not be forced into the combustion chamber and will go back into the intake manifold area.

    You are checking compression in the combustion chamber which has three areas to be sealed. 1 - Spark plug hole (spark plug). 2 - head to cylinder joint (head gasket) and 3 - piston to cylinder gap (rings). THe motor technically doesn't even need the entire lower end for compression to build in the combustion chamber. Failures that typically cause issues with compression are ring breakage / failure, and a holed piston.......

  10. #10

    Join Date
    May 2012
    Location
    Milwaukee Wisconsin Area
    Posts
    20
    BlueFishCrisis thanks for the clarification..will take apart the top end tonight..

    Paul

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Kawasaki STX 15f Loss of Full Power
    By dhart in forum Kawasaki How To & FAQs
    Replies: 6
    Last Post: 10-27-2016, 08:17 AM
  2. Kawasaki STX 15f Loss of Full Power
    By dhart in forum Kawasaki PWC Performance (4-stroke)
    Replies: 5
    Last Post: 07-29-2016, 09:59 AM
  3. Polaris slt 750 not running full speed
    By Carson in forum Polaris PWC Performance
    Replies: 4
    Last Post: 08-01-2011, 11:21 AM
  4. Replies: 5
    Last Post: 07-23-2011, 08:21 AM
  5. polaris SLT 750 no power
    By speaksr in forum Polaris Open Discussion
    Replies: 1
    Last Post: 04-11-2011, 12:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •