Results 1 to 8 of 8
  1. #1

    Wrong T in R&D Block Thermostat Kit

    Is it just me or is the T they include in the kit the wrong size? The T they have in the kit is 5/8" all around but my hose out of the thermostat to back is 3/4". I searched for a T that is 3/4 x 3/4 x 5/8 with no luck. So got 3/4 all around and a 3/4 to 5/8 reducer.


  2. #2
    maxadrenaline's Avatar
    Join Date
    Nov 2007
    Location
    RETIRED !! In Mobile AL or Wherever I Want To Go
    Posts
    1,414
    +1
    137
    We have run into the same question. The FZ is uses metric size hose.

  3. #3
    mckma's Avatar
    Join Date
    Mar 2011
    Location
    Kernersville N.C.
    Posts
    150
    +1
    1
    yep I had to use a different T as well cant remember what it was though

  4. #4
    Ace's Avatar
    Join Date
    Apr 2012
    Location
    NAPLES, FL
    Posts
    138
    +1
    5
    You're not the first one to have the wrong sizes in an R&D kit. They're instructions listed the wrong size holesaw I needed in my intake kit...kinda of a pain in the ass to go to Home Depot twice...

    The kit works tho!

  5. #5
    Oldnick oldnick's Avatar
    Join Date
    Aug 2007
    Location
    Forest Hill, MD
    Posts
    145
    +1
    10
    The hoses in my R&D engine/intercooler cooling kit were not all cut to the sizes in the instructions... Two were cut short!

  6. #6
    Just makes me wonder about R&D kits. I don't care much for the directions, I use Rivas most of the time.
    So far I have a few of their stuff. Ribbon delete, cooling kit (should have waited on this one), ride plate, and intake grate. So I like what they offer.

  7. #7
    Quote Originally Posted by maxadrenaline View Post
    We have run into the same question. The FZ is uses metric size hose.
    The difference here is more then metric and standard. But I do understand that too.

  8. #8
    Oldnick oldnick's Avatar
    Join Date
    Aug 2007
    Location
    Forest Hill, MD
    Posts
    145
    +1
    10
    I hate the R&D instructions, wish they would post on line like Riva... Very satisfied with all my R&D parts!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB - Parts 08+ In Tank Fuel Reg Block Off
    By Sayers in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 09-07-2012, 10:31 PM
  2. Xl1200 ltd rebuild gone wrong! Water in all cylinders.
    By toddnbrown in forum Yamaha PWC Performance (2-stroke)
    Replies: 11
    Last Post: 07-23-2012, 04:18 PM
  3. Wrong Engine in Speedster SC
    By Ducatifast in forum Sea Doo Sport Boats
    Replies: 27
    Last Post: 04-12-2011, 02:29 PM
  4. Anyone running an R&D FZR Block Thermostat Kit Cooling Option?
    By 5001craig in forum Yamaha PWC Performance (4-stroke)
    Replies: 10
    Last Post: 03-01-2011, 12:12 PM
  5. wrong fuse in the VTS
    By sea-one in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 01-10-2011, 01:16 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •