Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1

    Join Date
    Jul 2011
    Location
    Ct
    Posts
    158
    +1
    3

    2007 seadoo speedster 200

    I just bought a 2007 seadoo speedster 200 430 hp. which I was told it had around 90 hours on it.
    So I took it out yesterday and one engine is seeing around 7800 rpm and the other engine is only seeing around 6500-6800 rpm any idea what could cause this. I changed all the plugs out and also checked to see if it's getting full throttle.
    I don't think the guy ever checked the chargers for slip since he bought it new. Does this sound like it could be the super chargers slipping ?
    Also I know they need to come out anyway because they have the ceramic washers in there but just curious if I should check anything else why I'm at it.


  2. #2

    Join Date
    Jun 2009
    Location
    Tierra Verde, Florida, United States
    Posts
    911
    +1
    17
    you could take a quick look at the supercharger to make sure it's still ok. Just take the intake hose off the SC and see if you can turn the SC wheel with your fingers. You shouldn't be able to

  3. #3

    Join Date
    Jul 2011
    Location
    Ct
    Posts
    158
    +1
    3
    Yea thanks just found out that my washers are gone know what does the motor need to come out...all the needle bearings are at least there,can I clean out the oil screen or do you think the motor needs to come out.

  4. #4
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Motor has to come out.
    There are 2 oil screens. 1 for each oil pump.
    1 on each end of the motor.
    Try to reconstruct the broken washers to make sure u got them all.
    I know this very well.
    Yeah they all will or have broken.
    I just had a ski with 18 hrs and broken ceramic washers.
    Dealers / stealers charge over 2k to do it.
    My local pro builder charges 700 including the rebuild on the s/c.

  5. #5
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    There are 2 washers that are supposed to be there.
    And 40 needle bearings.
    I've heard jerry on this site is quick and very good at rebuilding chargers.

    On the charger with 7800 rpm u might not need to yank the motor if both washers are there.
    I havent seen a charger with broken washers go over 6k rpm.
    Just make sure both washers are found for each charger or you will be sorry..

  6. #6

    Join Date
    Jul 2011
    Location
    Ct
    Posts
    158
    +1
    3
    I pulled out both chargers just to make sure and one charger has both washers on it so I know that one is good but the other one has nothing on it so both washers are in the motor somewhere so I need to find them and see what condition they are in to deturmen if the whole motor needs to come out but from the sounds of it im sure it has to come out because I can't image the washers are going to be sitting there in large chunks.

    Also you said there are two oil pumps on these motors ?

  7. #7

    Join Date
    Jun 2009
    Location
    Tierra Verde, Florida, United States
    Posts
    911
    +1
    17
    Quote Originally Posted by Twinstang View Post
    I pulled out both chargers just to make sure and one charger has both washers on it so I know that one is good but the other one has nothing on it so both washers are in the motor somewhere so I need to find them and see what condition they are in to deturmen if the whole motor needs to come out but from the sounds of it im sure it has to come out because I can't image the washers are going to be sitting there in large chunks.

    Also you said there are two oil pumps on these motors ?
    One is in the PTO were the SC goes in to and the other is in the front of the motor. Get a shop Manual for the motor

  8. #8
    twinturbostang's Avatar
    Join Date
    May 2008
    Location
    CT
    Posts
    295
    +1
    3
    Why is there a Twinstang in CT that isn't me? Wait a sec?

  9. #9

    Join Date
    Jul 2011
    Location
    Ct
    Posts
    158
    +1
    3
    Quote Originally Posted by twinturbostang View Post
    Why is there a Twinstang in CT that isn't me? Wait a sec?

  10. #10
    twinturbostang's Avatar
    Join Date
    May 2008
    Location
    CT
    Posts
    295
    +1
    3
    Where in CT are you? Do I know you?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. for an inch cold air intake on a 2006 seadoo speedster 200
    By Jstcdoit in forum Sea Doo Sport Boats
    Replies: 4
    Last Post: 12-11-2013, 01:27 AM
  2. Just installed trim tabs on my 2006 Seadoo Speedster 200 - review:
    By wisconsin_quat in forum Sea Doo Sport Boats
    Replies: 9
    Last Post: 07-09-2013, 12:21 PM
  3. Seadoo Speedster 200 charging two batteries
    By Jeepboy in forum Sea Doo Sport Boats
    Replies: 10
    Last Post: 02-29-2012, 10:46 AM
  4. Replies: 7
    Last Post: 04-13-2011, 01:17 PM
  5. 2007 seadoo speedster Water temp sensor not accurate?
    By fugazi in forum Sea Doo Sport Boats
    Replies: 3
    Last Post: 12-28-2007, 01:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •