Results 1 to 6 of 6
  1. #1
    Brd-Prey's Avatar
    Join Date
    Mar 2012
    Location
    Lakeland, FL
    Posts
    242
    +1
    11

    2012 P-X sand debris filter I have one has anyone installed one yet?

    If so where and pics please.

    thanks Ed


  2. #2
    Brd-Prey's Avatar
    Join Date
    Mar 2012
    Location
    Lakeland, FL
    Posts
    242
    +1
    11
    Guess I'll be the first! I'll document thn post.

  3. #3
    ADAMBOMB's Avatar
    Join Date
    Mar 2006
    Location
    Sunrise,Florida
    Posts
    4,723
    +1
    196
    Yes, Some have installed the strainers. I personally dont like them and dont run one.

  4. #4
    Brd-Prey's Avatar
    Join Date
    Mar 2012
    Location
    Lakeland, FL
    Posts
    242
    +1
    11
    Quote Originally Posted by ADAMBOMB View Post
    Yes, Some have installed the strainers. I personally dont like them and dont run one.
    Please explain?
    \

  5. #5
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,494
    +1
    476
    sounds like he is too lazy to clean it

  6. #6
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. This inline water debris filter look familiar?
    By sea-one in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 01-23-2012, 04:27 PM
  2. Sand and Debris filter kit help needed on my RXTX 2008 model
    By stevea99 in forum 4-Tec Performance
    Replies: 4
    Last Post: 07-06-2011, 03:29 PM
  3. Anyone have the RR IC install instructions?
    By rx4pain in forum Sea Doo How To & FAQs
    Replies: 8
    Last Post: 07-18-2007, 10:45 AM
  4. Does anyone have one of these laying around some where?
    By Angelse68cal in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 08-10-2005, 04:08 PM
  5. So do we have any Riva Stage 2 Results yet?
    By Compwhiz82 in forum 4-Tec Performance
    Replies: 0
    Last Post: 06-20-2005, 11:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •