Results 1 to 3 of 3
  1. #1
    Full Throttle or Broke!!! UNSANE's Avatar
    Join Date
    Aug 2008

    Sea Doo ibr failure (backing up in neutral)

    I'm going to drop this here as well. After 3 months of going back and forth with them, they are refusing to address this problem. They are actually blaming this on the GPS bypass!!!! WTF!!! They say it's not a safety issue either! Watch how fast it starts to move back after 30 seconds. I let this happen 3 times for the camera, but I nearly backed into the CC at the fuel dock earlier.

    Here's the vid:

    I'm trying to find the right people in the Coast Guard or anyone that deals with these types of issues in general to contact.

    The service guy who denied all of this is named Bill (no last name) Sure would love a conversation with him.

  2. #2
    83Gator's Avatar
    Join Date
    Jul 2008
    St. Amant, LA
    This may not be related or is perhaps close but not the same issue, but this sounds familiar. Seems the individual "fixed" the issue by "shaving" the bottom 1/2 inch or so off the reverse bucket. IDK if it worked great, good, or somewhat, I certainly don't advocate taking a saw to a brand new machine under warranty. This was just some FYI... good luck w/your issue.

  3. #3
    wotxxxsd's Avatar
    Join Date
    May 2012
    My 09 gtx i.s. 255 has the same back up in neutral issue.
    It has never really bothered me.
    I've also heard of shaving down the reverse bucket to fix the issue.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts