Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
  1. #1

    Join Date
    May 2012
    Location
    Northern Va.
    Posts
    37
    +1
    1

    2001 SUV impeller/shaft questions

    I have decided to remove and inspect all of my hardware in the drive unit. I got the everything down to the pump removed. I noticed 2 things:
    1 - the shaft has a worn spot about 7" down from the splines. Not sure if I should worry about it. they are not very deep.
    2 - The impeller looks pretty bad on the leading edge, I guess I need to just purchase a new one.

    I also have order a new intake grate, shoe, and may be a ride plate. They were all pretty corroded from being a salt machine at one time.

    Click image for larger version. 

Name:	Impeller_Shaft_1.jpg 
Views:	43 
Size:	93.5 KB 
ID:	271829Click image for larger version. 

Name:	Impeller_1.jpg 
Views:	41 
Size:	129.5 KB 
ID:	271830


  2. #2

    Join Date
    May 2012
    Location
    Northern Va.
    Posts
    37
    +1
    1
    I just ordered a reconditioned impeller from SBT. I hope they get it to me soon. I really wanted to get this done over the weekend. I'm sure it is gonna have to wait. Bummed...

  3. #3

    Join Date
    May 2012
    Location
    Northern Va.
    Posts
    37
    +1
    1
    Does anyone have any idea if I need to worry about the wear on the drive shaft?

  4. #4

    Join Date
    Aug 2006
    Location
    Indiana
    Posts
    1,274
    +1
    81
    I wouldn't worry too much about it. The wear is from the 2 o-rings inside the intermediate shaft . They seal the pump splines from water and corrosion. You can polish the grooves up with scotch brite or something to smooth them up, and use plenty of grease on the splines and the groove area when you put it back together. The o-rings may be worn, they are located about 1/2" in on the Intermediate shaft. Not sure if you can access them easy on the SUV, you have to take the pump coupling hose off to see.

  5. #5

    Join Date
    May 2012
    Location
    Northern Va.
    Posts
    37
    +1
    1
    So I got my spline tool and guess what? It doesn't fit my shaft. It is way too small. I called the marina that sent it out and they claimed it was the right size. He had me measure my spline and it was 20mm. He is having one drop shipped to my house. Did Yamaha change the drive shaft size in the middle of production?

  6. #6
    Moderator OsideBill's Avatar
    Join Date
    Mar 2006
    Location
    United States
    Posts
    11,875
    +1
    30
    Nope they have always been 20mm, the older Yamaha skis were 18mm, the newer 4 strokes are 22mm. Your parts guy sent the wrong one thats all.

  7. #7

    Join Date
    May 2012
    Location
    Northern Va.
    Posts
    37
    +1
    1
    So, I was reinstalling everything tonight and found that the threads in the new wear ring housing have the wrong pitch. I am so ticked right now. I wanted to use this so bad this weekend. Should I try to get bolts that fit, or should I send back the wear ring and get the correct one? I ordered it from this guy selling them on eBay , guess that may be a mistake but they are only 85 bucks.
    Let me know whatcha think
    Thanks...
    Tony

  8. #8
    Moderator OsideBill's Avatar
    Join Date
    Mar 2006
    Location
    United States
    Posts
    11,875
    +1
    30
    what pitch are they? Yamaha is notorious for using the M10 x 1.25, when the rest if the world standardizes at M10x1.5 gotta love metric.

  9. #9

    Join Date
    May 2012
    Location
    Northern Va.
    Posts
    37
    +1
    1
    I haven't found out yet. All I know is that the Yamaha bolts don't screw into the new wear ring. I guess I will head to the hardware store to figure out what they are.

  10. #10

    Join Date
    May 2012
    Location
    Northern Va.
    Posts
    37
    +1
    1
    Just got back from the hardware store...
    I tried the following sizes and pitches:
    M10 1.00, 1.25, 1.50 I also tried 3/8"x16 and 24.
    Nothing seems to work. The threads look perfect.
    I don't know what to do other than return it.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2001 gp1200r crank shaft question
    By TuningForkMarine in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 12-20-2013, 03:41 PM
  2. WTB looking for a driveshaft and coupler shaft for 2001 SUV 66V
    By joewharton2 in forum Yamaha Classifieds
    Replies: 4
    Last Post: 05-26-2012, 10:10 AM
  3. 2001 and 2004 Yamaha 1200 SUV Primer pump question
    By macGruber in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 03-24-2012, 02:32 PM
  4. 02 gtx 4tec impeller shaft question
    By Jessie00721 in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 09-01-2011, 09:47 AM
  5. 2001 gp1200r drive shaft question with pic
    By SUBLIME808 in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 04-07-2011, 02:59 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •