Results 1 to 4 of 4
  1. #1
    chartersj's Avatar
    Join Date
    Jun 2011
    Location
    Grand Manan, New Brunswick, Canada
    Posts
    122
    +1
    3

    info center not working..rx 951..i've searched

    i have a 2000 seadoo rx 951, a couple weeks ago i did the fuel sending unit fix with solder to get my fuel gauge to work and it worked great. i started the machine up and worked perfect. today i decided to put the battery in to use it and now the info center is not working at all. The trim still works, and the speedometer to the right still works, but nothing on the digital display. All the modes worked, fuel guage, and the little red light all worked perfect when i took the battery out last. When i put the lanyard on it beeps twice. Any ideas where to start? thanks.


  2. #2

    Join Date
    Mar 2006
    Posts
    1,833
    +1
    119
    new gauge-- I seen what you are describing a number of times.

  3. #3
    chartersj's Avatar
    Join Date
    Jun 2011
    Location
    Grand Manan, New Brunswick, Canada
    Posts
    122
    +1
    3
    how can i tell for sure thats what it is? i noticed today it was working when i put the lanyard on at the house, but by the time i got to the bay is wouldnt work again..it seems intermitting

  4. #4

    Join Date
    Mar 2006
    Posts
    1,833
    +1
    119
    I have a seperate cluster setup from another machine that I plug into the mpem for testing purposes. The info centers do fail on a number of machines. If you are lucky, the anolog speedo still works as in your case. I never messed around w/ cutting anything open or trying to fix them, but it may be possible w/ enough time, patience and luck.

    On the 2 strokes, the info center is not required for normal operation of the machine. If the gauge on a 4 tech stops working, it throws the ski into limp mode

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1998 gsx info center stopped working
    By Svtkiller in forum 2-Stroke Performance
    Replies: 2
    Last Post: 06-15-2016, 09:01 PM
  2. VTS not working, Seadoo RX - PLEASE HELP
    By usrockband in forum 2-Stroke Performance
    Replies: 7
    Last Post: 07-01-2012, 06:07 PM
  3. Info center fuuel guage 951
    By Mighty Mouse in forum 2-Stroke Performance
    Replies: 6
    Last Post: 11-07-2011, 07:19 PM
  4. xp 99/98 951 one cylinder not working
    By BlackHawk in forum 2-Stroke Performance
    Replies: 8
    Last Post: 09-01-2010, 01:55 AM
  5. okay, not work safe. Grossest picture I've ever seen...
    By theantiRXP in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 07-19-2005, 09:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •