Results 1 to 4 of 4
  1. #1

    Genesis 1200 carb, is my problem unique

    I have been looking on this site for a few weeks trying to find a thread with my problem, but I have had little luck.

    2000 Polaris Genesis 1200 carbureted. Ran great last year, took it out once and it would not restart (it would crank/roll over just like the lanyard was out) when I went to load it on the trailer. It restarted the next day then died and would not restart. I did the orange wire bypass and it made the bilge pump run continuously so I disconnected it. The LR 505 tested bad so I replaced it, the motor started in the driveway just fine and seemed to run good, I killed it with the start/stop button and it will not restart. I'm lost. I ordered a CDI without testing the hall sensors or stator because of the intermittent start up. The new CDI will be in on Monday.

    CDI was replaced two years ago


  2. #2

    Join Date
    Apr 2008
    Location
    Canada - Brrrrr...
    Posts
    33
    I had a similar problem last year. The LR module went and overcharged the system. I replaced my stator as a result. CDI seemed to be okay.
    Is your Genesis running okay now with new CDI?
    Where did you manage to find a CDI?

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,601
    +1
    1,276
    Quote Originally Posted by caleou1 View Post
    I have been looking on this site for a few weeks trying to find a thread with my problem, but I have had little luck.

    2000 Polaris Genesis 1200 carbureted. Ran great last year, took it out once and it would not restart (it would crank/roll over just like the lanyard was out) when I went to load it on the trailer. It restarted the next day then died and would not restart.

    I did the orange wire bypass and it made the bilge pump run continuously so I disconnected it.

    The LR 505 tested bad so I replaced it, the motor started in the driveway just fine and seemed to run good, I killed it with the start/stop button and it will not restart. I'm lost.

    I ordered a CDI without testing the hall sensors or stator because of the intermittent start up. The new CDI will be in on Monday.

    CDI was replaced two years ago
    Sounds like the CDI to Orange wire modification was done incorrectly.

    Start/Stop module can be bypassed for testing.

  4. #4

    Join Date
    Jul 2009
    Location
    Nova Scotia
    Posts
    112
    CDI went on my 2001 Virage 1200 a couple years ago. Drove myself crazy trying to figure it out. After much trial and error and $ replaced CDI and she fired right up. I actually had a short in one of the wire connectors coming from the stator. I believe that is what did the CDI in.

    Good luck
    Alan

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Polaris Genesis 1200 1999 - Is This Worth Fixing??
    By sean_J in forum Polaris Projects
    Replies: 124
    Last Post: 12-25-2013, 03:25 PM
  2. So there is my problem right there, new member sl780
    By Tow-in-Barrels in forum Polaris Projects
    Replies: 72
    Last Post: 05-08-2012, 05:48 PM
  3. Ignition update Kit for 99 Genesis 1200 (Carb)
    By Cullyman in forum Polaris Open Discussion
    Replies: 4
    Last Post: 08-20-2011, 09:53 AM
  4. Need A Cylinder For Genesis 1200 carb
    By partsme in forum Polaris Open Discussion
    Replies: 0
    Last Post: 06-09-2009, 07:13 AM
  5. Info Needed On Polaris Genesis 1200 Carb
    By A1999polaris1200ccgenesis in forum Polaris Open Discussion
    Replies: 12
    Last Post: 06-29-2008, 07:56 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •