Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17

Thread: 1996 slt help

  1. #1

    1996 slt help

    New here need little help.Just bought 96 slt guy bought it off of said it had 30hrs on rebuild. took it to the river wife said ran good for 2hrs came close to shore stirred up mud and took off and it started to run rough the futher down river she ran it the worst it got. Until She had it full throttle wouldn't go any where then it shut off it would start but wouldn't stay running and wouldn't go . Towed it in got it on the trailer I went to start it started fine and reved fine and stayed running got it home started it again and it was fine . Kind of lost what could it be ?


  2. #2
    David Drkvampire2001's Avatar
    Join Date
    Jul 2011
    Location
    Edgerton, Wisconsin, United States
    Posts
    2,857
    +1
    30
    Possibly sucked up seaweed into the intake. blocking the prop from getting water, ive had that when traveling threw a channel have to stop turn engine off reach in and pull the crap out start then it goes.....

  3. #3
    just ran compression test the cylinder closes to the back reads only like 40 the rest read 125 whats my next step

  4. #4
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Quote Originally Posted by Coltsfan View Post
    just ran compression test the cylinder closes to the back reads only like 40 the rest read 125 whats my next step
    REBUILD!!!! Pop the head off the rear (MAG) cylinder and get some photos up for us to see......

    Welcome to the Hulk!!!!

  5. #5
    what could cause such a low compression reading? New to PWC and trying to fix it on my own and need all the help I can get

  6. #6
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    Remove the head and take some pics. We can better determine the cause from those.

    And just a FYI: the FRONT cyl is the MAG (short for magneto) and the REAR is the PTO (for Power Take Off)

  7. #7
    Low compression is caused by a number of things, numbers that low indicate the need for a re-build regardless of the cause. It is very likely that the piston has sustained damage. It could be from any number of things, like everyone said show us a picture and we can then get you pointed in the right direction.

  8. #8
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Quote Originally Posted by xlint89 View Post
    Remove the head and take some pics. We can better determine the cause from those.

    And just a FYI: the FRONT cyl is the MAG (short for magneto) and the REAR is the PTO (for Power Take Off)
    Ha ha.... typing too fast for my own good! Thanks for the correction......

  9. #9
    I read it and didnt even notice it. I thought xlint was just teaching him the lingo, don't go filling new comers heads with bad ideas

  10. #10
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    Quote Originally Posted by nick072010 View Post
    I read it and didnt even notice it. I thought xlint was just teaching him the lingo, don't go filling new comers heads with bad ideas
    I was, with a subtle little correction to BFC.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help on 1996 SLt 780
    By Mark1505 in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 06-28-2015, 10:52 AM
  2. 1996 SLT 780 Top End on 1995 SL750 help
    By mikefromedson in forum Polaris Projects
    Replies: 3
    Last Post: 09-29-2011, 09:17 PM
  3. My 1996 SLT 780 won't start, just clicking sound please help!!
    By smitty564 in forum Polaris How To & FAQs
    Replies: 5
    Last Post: 07-28-2011, 08:35 AM
  4. 1996 SLT terminal board help!
    By robeastunder in forum Polaris Open Discussion
    Replies: 5
    Last Post: 07-14-2011, 04:24 PM
  5. Help advise-1996 SLT 700
    By polaris slt700-darn in forum Polaris PWC Performance
    Replies: 1
    Last Post: 07-28-2009, 10:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •