Results 1 to 3 of 3
  1. #1
    yol937's Avatar
    Join Date
    Jul 2011
    Location
    Nc
    Posts
    1,071
    +1
    160

    Afr gauge problem

    At cruising speed afr gauge fluctuates in the 12.2 to 12.6 range and then it will jump up to the 21.4 to 21.10 range and says there . But if u cut off and turn back on it will work fine for a lil but reading back in the 12 range and will shoot back to 21 range and stay but if u keep turning off and turn back on it will work fine then go back to messing up.. It's a innovative digital gauge with Lc cabled does anybody have a clue what's going on is it the o2 sensor, bad gauge? Any help would be appreciated thanks


  2. #2
    tealgreen2000's Avatar
    Join Date
    Jul 2010
    Location
    miami gardens
    Posts
    305
    +1
    8
    Quote Originally Posted by yol937 View Post
    At cruising speed afr gauge fluctuates in the 12.2 to 12.6 range and then it will jump up to the 21.4 to 21.10 range and says there . But if u cut off and turn back on it will work fine for a lil but reading back in the 12 range and will shoot back to 21 range and stay but if u keep turning off and turn back on it will work fine then go back to messing up.. It's a innovative digital gauge with Lc cabled does anybody have a clue what's going on is it the o2 sensor, bad gauge? Any help would be appreciated thanks
    you are correct the o2 sensor is bad thats what mine does every time it goes bad

  3. #3

    Join Date
    Sep 2008
    Location
    NE Ohio
    Posts
    306
    How about an air leak or an O2 sensor that is out of range, the latter is quite possible they do not like water. Not to steal the this thread, but, for those with an Innovate system that are also logging rpm's, where did you pick up the rpm trigger. The wires under gauge do not work, the Innovate hardware does not like the signal, I cannot get it to read accurate

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Innovate mtx-l afr gauge problem
    By yol937 in forum Yamaha PWC Performance (4-stroke)
    Replies: 3
    Last Post: 10-25-2015, 09:05 PM
  2. Innovate mtx-l afr gauge problem
    By yol937 in forum 4-Tec Performance
    Replies: 1
    Last Post: 10-24-2015, 11:43 AM
  3. Gauge problems
    By explude in forum Polaris How To & FAQs
    Replies: 60
    Last Post: 03-26-2008, 08:46 PM
  4. Gas gauge problem!
    By dcs191919 in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 09-05-2007, 07:45 AM
  5. Weird Gauge Problem
    By '02GPRider in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 04-09-2007, 11:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •