Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 38
  1. #1

    2001 GP800R cavitating really bad!

    Hey everyone I have a problem that I can't seem to figure out.

    I rebuilt the top end and rebuilt the powervalves and put a whole new jet pump on it because the housing was bad and I found a complete pump cheaper than it would've been for just a housing and I am still having horrible cavitation.

    The motor will idle and start fine but I'll give it half throttle and the rpms jump to 7000 and it won't go anywhere.

    The driveshaft splines are in perfect condition so I know that it's not just spinning.

    The intake grate is siliconed all the way around also.

    The ski has exactly 100 hours on it.

    Any input would be greatly appreciated.
    Thanks


  2. #2
    Moderator OsideBill's Avatar
    Join Date
    Mar 2006
    Location
    United States
    Posts
    11,875
    +1
    30
    is the pump shoe sealed?

  3. #3
    I never did seal up the pump shoe, but I can try it.

    I'm thinking it's something to do with the powervalves.

    Today on the lake I was trying to figure it out so I disconnected the pv motor and turned the powervalves counter clockwise and the ski wouldn't go over 5 mph or 2000 rpms.

    I tryed also turning the powervalves clockwise and it would just cavitate all over again.

    The pv motor does cycle when I shut it off.

    Could the pv cables be crossed maybe?

  4. #4
    Moderator OsideBill's Avatar
    Join Date
    Mar 2006
    Location
    United States
    Posts
    11,875
    +1
    30
    do some searches here, it is the number one reason for cavitation.

  5. #5
    Ok.
    I will try sealing the pump shoe.

    It's just hard for me to believe that the pump shoe would do it because the cavitation is almost instant and I can't get over 5 mph.

  6. #6

    Join Date
    Aug 2008
    Location
    Greensboro nc
    Posts
    43
    Have you checked the splines inside the intermidiate shaft.. H ad mine strip out and drive shaft showed now signs of damage

  7. #7
    I have not pulled the intermediate shaft out but I'll take a look at it.

    I'm also going to check the stator because I have heard of one of the coils going bad and causing this problem.

    Thanks for the insight.
    I didn't really think about the intermediate shaft.

  8. #8

    Join Date
    Aug 2008
    Location
    Greensboro nc
    Posts
    43
    You can pull the pump and the drive shaft out and look thru the opening for the drive shaft with a flash light. Dont have to pull it out to check it.

  9. #9
    Gotcha.
    I didn't have time today to do it but probably tomorrow.

    I'll let everyone know what the outcome is.
    Thanks

  10. #10
    I am stumped with this ski.
    It wont go over 6 mph.

    It will go from 2,000 rpm and jump to 8,000 rpm and then back to 2,000.

    Any help would be great.

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS: 2001 KAWI STX 900, bad motor, nice hull, $975
    By AugRemy in forum Kawasaki Skis
    Replies: 0
    Last Post: 07-28-2008, 08:39 PM
  2. Ran fine and now it's shuttering really bad
    By DavyBoy in forum Kawasaki PWC Performance (4-stroke)
    Replies: 7
    Last Post: 07-22-2008, 06:32 AM
  3. 2001 gp800r compression
    By stingray152003 in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 09-04-2007, 04:38 PM
  4. What do you think? bad, really bad, or ok?
    By RXPteamtimebomb in forum Sea Doo Open Discussion
    Replies: 16
    Last Post: 03-23-2007, 11:56 AM
  5. is this really bad??
    By bow tie klr in forum Yamaha PWC Performance (2-stroke)
    Replies: 8
    Last Post: 03-21-2007, 03:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •