Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20
  1. #1

    Running submersibles yet replacing every 2-4 trips out to the lake

    I am even unplugging before backing into the water and have even siliconed where the exisiting gasket was just to see if that would make a difference. Is this pretty common or is their a betterset of lights I could try other than walmart/gander mountain etc.


  2. #2
    83.0 @ 8400 jhill19's Avatar
    Join Date
    Jul 2010
    Location
    Teays Valley, West Virginia
    Posts
    2,800
    +1
    81
    I've had my trailer for 3 years now and have yet to replace a light on it I am going to switch mine over to LED's this year. because I broke a few lens in the garage

  3. #3
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Unplug your lights before u back in the water.
    Water and electronics don't mix well...
    Imo

  4. #4
    Quote Originally Posted by wotxxxsd View Post
    Unplug your lights before u back in the water.
    Water and electronics don't mix well...
    Imo
    Have been, and its not always the same light as far as driver or passenger just randomly one will just stop working.

  5. #5

    Join Date
    Sep 2010
    Location
    West Palm Beach
    Posts
    15
    Did you check the ground on the light that isn't working? If my ground wire comes loose on my lights they stop working until it is fixed

  6. #6
    these lights im running dont have a ground wire. all i have are 1 brown and 1 yellow wire. The one I got from walmart has a green ground and it is still working.

  7. #7

    Join Date
    Oct 2011
    Location
    aurora IL
    Posts
    316
    check your vechicle side. also. not just trailer.....

  8. #8
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    I dont think that green wire is a ground.

  9. #9
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    Quote Originally Posted by jhill19 View Post
    I've had my trailer for 3 years now and have yet to replace a light on it I am going to switch mine over to LED's this year. because I broke a few lens in the garage
    I just upgraded my trailer lights Monday. I ordered them from etrailer.com. Great price and great quality and most of all Sealed and submersible.

    This is the kit I bought. Made by optronics and a more top-of-the-line kit. Made for the water. Very bright....

    http://www.etrailer.com/p-TLL9RK.html

  10. #10
    Quote Originally Posted by troyheb View Post
    I dont think that green wire is a ground.

    White wire i mean. my bad.. Any ideas yall on why this is happening

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 11
    Last Post: 08-03-2013, 04:03 PM
  2. Replies: 4
    Last Post: 07-11-2009, 02:25 AM
  3. How to run a seadoo out of the water
    By Davpmars in forum 2-Stroke Performance
    Replies: 18
    Last Post: 05-08-2009, 06:24 AM
  4. Replies: 30
    Last Post: 04-11-2008, 07:32 PM
  5. Covert Run, by Jammer 1 I missed you guys, Time to ski!
    By Jammer 1 in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 08-02-2006, 05:57 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •