Results 1 to 6 of 6
  1. #1

    AFR Gauge Reading Eratic.....

    Ive noticed the last couple of times at the water that my AFR gauge is acting crazy. On some passes it shows 13.0, on others 11.9. If you pull the throttle in slow it shows lean 13.0. If you stab the throttle to Wide open it will read 11.8. Any one see this before. It is a digital led gauge....


  2. #2
    Kristian Keppel Waterholics's Avatar
    Join Date
    Apr 2010
    Location
    Trinidad & Tobago
    Posts
    1,405
    +1
    38
    What gauge is this ? Is it an innovate gauge ?

  3. #3
    FZS Monty's Avatar
    Join Date
    Apr 2011
    Location
    Eastern Long Island, NY
    Posts
    588
    +1
    37
    Quote Originally Posted by OutlawGPR View Post
    Ive noticed the last couple of times at the water that my AFR gauge is acting crazy. On some passes it shows 13.0, on others 11.9. If you pull the throttle in slow it shows lean 13.0. If you stab the throttle to Wide open it will read 11.8. Any one see this before. It is a digital led gauge....
    Does it have a calibration procedure? my innovate does.

  4. #4
    gordon lasiter #328's Avatar
    Join Date
    Aug 2008
    Location
    katy, texas , United States
    Posts
    1,647
    +1
    28
    Quote Originally Posted by FZS Monty View Post
    Does it have a calibration procedure? my innovate does.
    +1. it needs a taste of fresh air.

  5. #5
    It is the innovate. I will calibrate it....It aslo goes to a flashing 7.4 sometimes during cruising sometimes. I can kill the power turn it back on on it starts working again....

  6. #6
    gordon lasiter #328's Avatar
    Join Date
    Aug 2008
    Location
    katy, texas , United States
    Posts
    1,647
    +1
    28
    Quote Originally Posted by OutlawGPR View Post
    It is the innovate. I will calibrate it....It aslo goes to a flashing 7.4 sometimes during cruising sometimes. I can kill the power turn it back on on it starts working again....
    Yep, it needs to be re calibrated.

    By chance did you run it at all with the sensor unplugged?
    I had the 7.4 reading before due to running it on the hose and did not realize the sensor was not plugged in. did a re calibration and it was all good.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. AFR gauge in RXP?
    By inteljd in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 01-21-2013, 10:11 PM
  2. AFR Gauge reads 22.4 at wot.
    By ultramaxracing05 in forum 4-Tec Performance
    Replies: 33
    Last Post: 06-11-2011, 08:48 PM
  3. 2000 kawasaki ultra 150 gas gauge reads 3/4 when empty?
    By trent0416 in forum Kawasaki Open Discussion
    Replies: 3
    Last Post: 07-11-2008, 09:48 PM
  4. Air/Fuel gauge readings
    By Bamafanatic in forum 4-Tec Performance
    Replies: 0
    Last Post: 05-07-2007, 08:30 AM
  5. Fuel gauge reads FULL when not...
    By BD in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 05-31-2006, 12:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •