Results 1 to 5 of 5
  1. #1
    David Drkvampire2001's Avatar
    Join Date
    Jul 2011
    Location
    Edgerton, Wisconsin, United States
    Posts
    2,857
    +1
    30

    95 SLT Issues after Carb rebuild/ fuel upgrades

    alright, redid the fuel system in my buddys 95 SLT, all the lines, rebuilt the carbs put to stock settings as they where a little screwy. got everything back together tonight, ran it a few times on land then decided to take it to lake so we did not overheat it, alright with the idle screw backed ALLLL the way out ( like not touching ) it idles in teh water at 1,900 RPM....if you turn left with it on the trailer and give it no gas it dies, turning right does nothing. took it on the lake bogs when you full out smash it but if you slowly accelerate it goes...ideas? suggestions? im lost...


  2. #2
    johnsonmtz's Avatar
    Join Date
    Oct 2006
    Location
    Mt. Zion Illinois
    Posts
    1,250
    +1
    7
    Screwy idle that changes with movement of the steering sounds like a bad throttle cable. Or you could possibly just have the cable in a bind. Try disconnecting the throttle cable and setting the idle. If that works it could mean his cable is corroded and needs replaced. Also, be sure all the butterflies are in sync. Having one more open than the others will cause a goffy idle.

    Bogging off idle sounds lean. Did you check the pop off pressure? Maybe the needles aren't opening causing fuel starvation.

    KJ

  3. #3
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    I already told you that the carb sync probably isn't right. Pull off the rack and check it again. 80g spring and 2.0 needle and seat were installed. Popoff should be right.

  4. #4
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Or you could have no free play in the throttle lever, not letting the carbs close all the way...... Or a messed up lever on the oil pump not letting the carbs open properly........

  5. #5
    David Drkvampire2001's Avatar
    Join Date
    Jul 2011
    Location
    Edgerton, Wisconsin, United States
    Posts
    2,857
    +1
    30
    LOL, ya those problems might cause that!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Adjustments after carb rebuild 95 GTX
    By pharmacist25 in forum 2-Stroke Performance
    Replies: 0
    Last Post: 07-17-2016, 11:59 PM
  2. 97 GTX No Spark after carb rebuild/fuel line replacement
    By Greyhair in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 06-06-2013, 03:40 PM
  3. No fuel slh700 after carb rebuild..
    By Nate414 in forum Polaris How To & FAQs
    Replies: 2
    Last Post: 06-18-2011, 01:35 AM
  4. GP1200R Bog after carb rebuild
    By Goliath in forum Yamaha PWC Performance (2-stroke)
    Replies: 16
    Last Post: 07-14-2010, 06:11 PM
  5. 96 sl700 wont idle after carb rebuild! HELP!!
    By schlik83 in forum Polaris Open Discussion
    Replies: 3
    Last Post: 08-03-2009, 10:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •