Results 1 to 8 of 8
  1. #1

    Join Date
    May 2012
    Location
    mobile al.
    Posts
    24

    Please help 2002 genisis hard to start

    I have a 2002 genisis 1200 fuel injected. Having starting issues. At first the only way i could start it is by taking off the return and sending fuel lines and putting them back on. Then i read up on the regulator issue. Sure enough mine was off and laying in the tank. Put the regulator back in and still the same issue. I can spray starter fluid in the throttle boddies and it will crank and run fine untill i shut it down. Cant get it to restart after it sets a few min. Any help would be great.


  2. #2
    jackofalltrades's Avatar
    Join Date
    Aug 2010
    Location
    Cabot Arkansas
    Posts
    592
    I see you figured out how to post. I replied to your PM as well. As I said, ground the brown wire at the fuel pump and see if it kicks on and check for fuel pressure on the return line. Let us know what you get. Cheers.

  3. #3

    Join Date
    May 2012
    Location
    mobile al.
    Posts
    24
    Thanks for the reply. Sorry i posted in the wrong section. Great site. Love the education. Well i checked fuel preasure and im getting around 19lbs without the return line pinched off and about 21 psi with the return pinched. Any more ideas . thanks Steve

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,589
    +1
    1,273
    Quote Originally Posted by pierceboy1972 View Post
    Thanks for the reply. Sorry i posted in the wrong section. Great site. Love the education. Well i checked fuel preasure and im getting around 19lbs without the return line pinched off and about 21 psi with the return pinched. Any more ideas . thanks Steve
    At some point a moderator might combine your threads into one.

    Only 21 PSI with return line pinched suggests either you didn't pinch it all the way or the fuel pump is getting weak. That said, 19 PSI is enough to allow the engine to start.

    Get the starting problem fixed, then consider replacing the fuel pump to avoid potential engine damage if the fuel pump weakens any further.

    As I posted in another of your threads, I suspect you have the classic low injector voltage problem. See my signature links for how to diagnose.

  5. #5

    Join Date
    May 2012
    Location
    mobile al.
    Posts
    24
    Man i know this is a dumb question, but how do i get to your signature link. Im learning the ropes . sorry. Steve

  6. #6
    jackofalltrades's Avatar
    Join Date
    Aug 2010
    Location
    Cabot Arkansas
    Posts
    592
    Right below his post. You can also click on his avatar and go from there. To check the injector voltage, check the red/white wire going to the injectors without unplugging any of them. You should get about 20V DC while cranking and if it were to start 45 V DC +. Cheers.

  7. #7
    Good advice. You may want to change out your fuel as well.

  8. #8
    jackofalltrades's Avatar
    Join Date
    Aug 2010
    Location
    Cabot Arkansas
    Posts
    592
    They fuel would have to be really old for it not to fire at all on the injected system. Can make it run like crap if its old but it should at least start unless the ski has been sitting for a long period of time.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2002 XLT's hard to start under load
    By Diznasty in forum Yamaha PWC Performance (2-stroke)
    Replies: 11
    Last Post: 06-02-2013, 10:44 AM
  2. 2002 Polaris 1200 TXI very hard to start.
    By Jkstr in forum Polaris Open Discussion
    Replies: 1
    Last Post: 09-25-2011, 05:55 PM
  3. 2002 gtx hard to start
    By Jessie00721 in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 08-11-2011, 08:45 PM
  4. XLT1200, hard to start then IDLEs to almost WOT! Help!
    By richdash in forum Yamaha Open Discussion
    Replies: 3
    Last Post: 07-26-2010, 03:08 PM
  5. Gp1200r engine boging down during accerlation and hard to start!!!! help!
    By jankyxl800 in forum Yamaha PWC Performance (2-stroke)
    Replies: 12
    Last Post: 03-30-2010, 01:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •